Orange LED vexnet Transmitter

Hi everyone,

The problem im facing is that the Vexnet LED on the transmitter is a fast orange blink (which apparently means “Linked ‐ Data quailty reduced”) this happens even if the Transmitter and receiver are very close to each other. The brain (PIC v.5) flashes a slow green robot LED stating controller 1 is linked (there is only 1 controller)

I also cannot load the programming through the transmitter, but it does load directly to the brain. I have so far not been able to do a single command through the Vexnet, as there is no response from any controls or motors.

Ive tried resetting both modules, swapping keys, transmitters, brains, and re-programming. Ive also done a combination of the above.

The brain is using the latest firmware, and I’m currently using the latest version of Easy C

The vexnet has been used previously with no issues, im not sure what has happened, but it is now giving me these issues.

Could someone please help me with this issue?

Thanks in Advance

Since we can’t read your mind about what you think are the
“latest firmware” and “latest version of Easy C”,
it may help if you report the specific versions of every item.

New alkaline batteries in the remote are always a good thing to try also.

You didn’t mention plugging the vexnet into the Pic v.5, or swapping that cord.

Thanks for listing the many things that you did try.
What do you mean by “reset both modules”?
Did you try linking with an A-A cable instead of Vexnet Keys?

Do you mean that it never worked when you tried it, but another person had previously used it, and it worked fine? Those two statements conflict if the situation were otherwise…

If the transmitter side is displaying only a blinking green robot light - there is a fix you can try. This fix only pertains to the transmitter unit.

Do not attempt this fix on the receiver (robot side). Again - this pertains only to the transmitter.

1- Make sure you have power connected to the unit, that it is off, and remove the VEXnet USB Key.

2- On the front of the unit, there is a small hole labeled “Config”.

3- Turn the unit on. The Robot light should be blinking slowly. Press in the config switch and hold until the Robot light begins to flash rapidly.

4- Release the Config button. The middle VEXnet light should briefly flash red.

5- Turn the unit off.

6- Now you will need to re-pair the unit with a corresponding receiver. To do this, connect both units with the A-A USB cable. Power both on and wait for a slow blinking Robot light and a solid VEXnet light. The units are now paired and ready for normal operation.

I hope this fix works for you. Feel free to contact me directly or call us at 903-453-0802 if you require further assistance.

To answer the questions…

@jgraber - The Brain is on V10 Easy C Firmware, and the Software is Easy C V2.9. The batteries have always been used fully charged, and ive replaced them too. I reset both modules by holding down the config button on both. And I have tried to pair them using the USB Male - Male cable, however, all this does is start the robot light blinking on the transmitter, and a solid green light on the “Game” Led of the Transmitter.

@octanetripledax - Sorry for the misunderstanding, the Vexnet has never worked when I tried it, but another person has previously used it, and it worked fine for them. I have asked them about this Vexnet issue, and they seem as puzzled as me.

@Sean Daugherty - I have not yet had a chance to try your fix, I will try and report on it as soon as I can.

following Sean Daugherty’s explanation the VEXnet is as follows

USB connected Brain
GAME LED - Solid Green
VEXnet LED - Nothing
Robot LED - Slow Green Blink

USB connected Transmitter
GAME LED - Nothing
VEXnet LED - Solid Green
Robot LED - Solid Green + Occasional Blink

Key connected Brain**
GAME LED - Nothing
VEXnet LED - Nothing
Robot LED - Slow Green Blink
*Key is solid blue

Key connected Transmitter
GAME LED - Nothing
VEXnet LED - Fast Orange Blink
Robot LED - Nothing

  • Key has constant blue blink

~ The VEXnet is still not working, I have re-loaded the programming, and have used fresh batteries after this.

Our team was using the unit they now have fine (we have upgraded to cortex) after the worlds we did a few displays and then took it off the robot for them, after that it hasn’t worked

Based on the Cortex Joystick quickstart guide to color codes,
(hopefully applicable to general vexnet color codes)
Vexnew fast yellow/orange blink means searching for mate.

ah, are you trying this in a school building with Cisco WIFI infrastructure products that are set to block ad-hoc wifi connections by using DOS attack?
In that situation, it worked exactly once, and then never after.
Try taking the setup to a different environment, like the parking lot or at home to see if it works better. What is the WIFI environment like in your room?

When tethered with the USBA-A cable, does it drive ok? (solid green vexnet light?)

Are there any other vexnet transmitters on in the same room?

When you download the program using the direct orange cable to the CPU,
are you downloading the firmware as well as the program?

When out team was using his unit, we could use it fine in our school. So i dont think there are any wifi blockers. The vexnet up grade doesnt work but the cortex vexnet does, if there was a blocker i would suspect it would block the cortex also.

To answer the other questions, jgraber

We have downloaded the programming directly to the Brain multiple times, we have also loaded up the firmware again on this brain, however, we haven’t loaded up the firmware every time we program directly to the brain.

The Robot doesn’t drive even when its tethered with the USB AA cable.

We have one other vexnet team, who are using the Cortex System

When having trouble like this, it can be important to download the firmware first, then download the program, (in that order).

Since your other vexnets work, it is not likely an IP blocker problem.

You’ve swapped Vexnet keys between working and unworking setups,
and all the Vexnet keys work in the working system,
and dont work in the non-working system,
so it isn’t a vexnet key problem: (right?)

When you take away the vexnet, and just use a phone handset cord tether, does the program you have loaded work correctly? That would show that the cpu works normally, or not.

Ive finally got VEXnet working now, thanks to Sean Daugherty, for anyone else getting similar issues to me, I did the following

download, extract, and install this utility here:

You will want to flash the units using this process (it works the same for both units):

  1. Connect the USB cable to your computer and open the firmware upgrade utility.

  2. With the unit powered off, depress and hold the “Config” button. While holding down the button, insert the USB cable into the unit and after a second or two, release the button. If done correctly, you should now have a rapidly flickering Robot light and a blinking Game light.

  3. On the firmware utility, click “Search”. You should then be able to click “Download”. A progress meter will be displayed and the VEXnet light should blink red a few times. After appoximately 45 seconds - the unit will reset and display only a solid green VEXnet light. You can then disconnect the USB cable from the unit.

  4. Repeat this process with the corresponding unit (although you should not have to press “Search” as the program has already been initialized).

  5. Once the other unit is finished, pair the two using the USB cable.

After this, pairing and re-programming, the VEXnet functions perfectly.

Thanks alot for all those that helped and offered ideas and solutions, especially Sean Daugherty

Thanks for sharing with the community Sir Prospect.

Please note though - this process should only be performed as needed, at the direction of tech support here at VEX Robotics. And this only applies as shown to the VEXnet Upgrade Bundle - not the Cortex Kits.

Glad to hear the issue was resolved. VEX on!