P Loop Bug

So I have been working on a P-loop recently and I run into a bug. I can’t seem to figure out why the rotation is an error.

I want the motor to slow down over time as I hold the L1 button.

'''// ----------------------------------------------------------------------------
//    Project:                                               
//    Author:
//    Created:
//    Configuration:        
// ----------------------------------------------------------------------------

// Include the V5 Library
#include "vex.h"

// Allows for easier use of the VEX Library
using namespace vex;

//Drivetrain Group
motor_group driveL(LeftFMotor,  LeftBMotor);
motor_group driveR(RightFMotor,  RightBMotor);

// Begin project code

void preAutonomous(void) {
  // actions to do when the program starts
  Brain.Screen.print("pre auton code");
  wait(1, seconds);

void autonomous(void) {
  Brain.Screen.print("autonomous code");
  // place automonous code here

void userControl(void) {
  // place driver control in this while loop
  while (true) {

double kP = 0.014;
int error = 0;
int targetValue = 900;


error = Tilter.rotation(degrees) -  targetValue;

if(Controller1.ButtonL1.pressing()) {
Tilter.spin( directionType::fwd, error * kP, voltageUnits::volt );




    wait(20, msec);

int main() {
  // create competition instance
  competition Competition;

  // Set up callbacks for autonomous and driver control periods.

  // Run the pre-autonomous function.

  // Prevent main from exiting with an infinite loop.
  while (true) {
    wait(100, msec);

edit: code tags added by mods, please remember to use them.

I had a similar issue with my cata pid. What you need to do is do targetValue - Tilter.rotation(degrees).

Screenshot 2024-02-13 5.45.02 PM
So I tried to build my P-Loop function but the “rotation” keeps showing up as an error. Messing around with it for a little while now, I am stumped on how to fix it. Am I missing something?

I think you have to use Tilter.position(degrees); instead of rotation.