Partner controller problems

Hi, I have been using the partner controller for quite some time now with no issues. However, about an hour ago the partner controller seems to not be working. When I connect my main controller to my Cortex without the partner controller plugged in, all the lights are green on the main controller. But when I plug in my partner controller, All the lights on the main controller turn off but the VexNet one, which blinks red twice every so often. Not only that, but the subsystems that are linked to the partner controller have no response. Both the main and partner controller have fully charged batteries, and the partner controller’s lights are all green. I have tried troubleshooting and updating, but nothing works. What should I do?

For some reason we found it the best way to pair the joysticks was to first turn everything off. Connect parter cable to the main with the the partner cable (still both powered off), turn on the cortex, turn on the main joystick, turn on the partner. Also, if you can get a hold of another partner cable that might help, sometimes the pins can get damaged. @Ryan_26982E

I’ll try that, but I did do something similar with no luck.

Is your partner controller cable connected to the MCU port on your partner controller?

I have had this problem once. My team and I first turned both joysticks and the cortex off. Then we replaced the batteries in both joysticks with fresh, charged ones, and replaced the robot battery as well (we thought the problem might be the cortex’s connection). Then we updated the firmware on the cortex and vexnet. Then we took the vexnet keys out of both the cortex and the main joystick and blew air vigorously (to remove dust or as such which might be causing connection problems) into the vexnet key side as well as the port side of the usb connection (always works). We did the same for the partner joystick connection cable (the blowing thing). Then we re-inserted the partner cable. Then we made sure the cable was plugged into the “partner” port on both joysticks. Then we turned everything on and re-paired the main joystick and cortex. Then we re-inserted the vexnet keys and voila, the connection was secure and we were able to control the robot fully again. One or more of these things must have worked but I dont know what exactly, so I suggest you try it all. Hope you regain control of your robot soon.

That’s… a bit excessive, especially considering the VEXnet connection is unrelated to the issue at hand.

I’ve seen it multiple times where the partner cable was simply plugged into the MCU port instead of the Partner port, thus causing the red lights.

I honestly don’t believe it is a VexNet issue, as the main controller works perfectly on its own and shows all green lights along with the cortex.

Let me just simplify this. Would the problem still persist if you try replacing the main joystick and/or CORTEX? If you don’t have one I think there may be some communities out there that can allow you to borrow a CORTEX and joystick for a simple second or so just to troubleshoot.

One item that I’ve made sure we do is to put a match mark of some kind on the correct ports that the partner connects to. We have had occurrences where they get plugged into the wrong port and cause problems. Having the connector and receptacle marked makes it more unlikely for that to happen.

After trying you suggestions with no success, I will try contacting official tech support for help. Thank you all for your input!