Pneumatic Problems with Cortex to Solinoid

The pneumatic’s on our robot are malfunctioning by not firing off when the button on our controller is pressed. We tried trouble shooting with a new cortex and found nothing, the cortex would work correctly bu the solenoid would work while not connecting such as when you turn on the cortex. I need any help.

Can you post the code (using the forum’s

 tags, which can be generated by clicking on the # symbol on the forum response toolbar) for us to take a look at please? Also, which programming language are you using?

Thank you in advance!

Its not the coding that is the problem, we tried it on another robot and it works. The code is not the problem.

Hi Et4000,

I’m sorry that you’re having this issue. Since the same code works on another robot, it most likely means that there is a problem with your solenoid. I suggest checking/trying the following:

  1. I know it sounds silly, but is your solenoid plugged into the correct port on your Cortex?

  2. There could be a problem with your solenoid driver cable. Have you tried switching the cable?

  3. There could be a problem with the solenoid itself. A piece of teflon tape or other type of debris could have gotten into your air system and caused your solenoid to seize. Does the solenoid fire whenever the orange button on your solenoid is pushed? Have you tried switching solenoids?

Give these things a try and let me know how it goes.

-Charles