Pneumatics Programming

So we decided to add pneumatics to our robot today. We got them mounted to the robot and it works manually but when we programmed it, they wouldn’t work.

We have the pneumatics plugged into port 5 and we are pressing the right button. We have no clue what we did wrong.:confused: Help we have a tournament in less than a week!

Did you try both buttons on that side.

In the code - do you have anything else using the same button sequence. In otherwords, is ANYTHING else mapped to the 7/2 button? It can cause problems if you do.

Also, consider using Joystick to Digital with a Latch - may work better depending on how you are using the pneumatics.

We tried all the buttons and nothing happened. We also tried a latch but that didn’t help it either and we have nothing going to 7/2 besides what i posted.

Try checking to make sure your tubing/wiring is correct. You can double check on the product description for your pneumatics kit (single/dual acting) Then, in controller configuration, make sure that port 5 in your controller configuration is set as an output (arrow pointing away from pin).

That might solve our problem. We had the arrow going the other way. I will download this to our robot and see if it works.

It worked!!! Thank you!!!