Port 1&6 Problem & Wireless Problem

Setting up my VEX IQ I have had the following problems:

  1. Port 1 & 6 not responding
  2. Wireless radio not being picked up

I have updated the firmware and tested all the motors ( they are good). The motors come up as attached to the brain on 1 & 6. However the controller when tethered to the robots does not control the motors.

I am based in the UK. I am hoping to run a course with the VEX robots in 3 weeks and need to get over these difficulties.

Hope we can sort this glitch out.

Gabriel

Gabriel,

Unfortunately there was a delay in the release of the 2.4 Ghz Wireless Radio firmware for the Robot Brain and the Controller; the existing 1.08 firmware only supports the 900 MHz Radio for North/South America. We are diligently working to get this firmware finalized as soon as possible. We are very sorry for any inconvenience this may cause.

Until the next version of the Robot Brain and Controller firmware is released, you will be able to drive your robot autonomously and via Tether Cable.

To help diagnose the problem with your Controller, please connect your Controller to your Robot Brain with the tether cable, and turn on the Robot Brain. In the top right corner of the LCD screen on the Robot Brain you should see two icons, a cable icon and a battery icon. The cable icon represents that the Robot Brain is tethered to a Controller. Do you see this Tether Icon?

If the Robot Brain and Controller are tethered, we now want to check the current Driver Control program settings. Use the Up/Down arrow buttons to select the Driver Control program then press Check. Scroll down to highlight Configure, then hit Check. The Robot Brain LCD should now display a list of settings for the Driver Control program. The top line says “Control” followed by either “2 Joystick”, “Left Stick” or “Right Stick”. Here is a brief explanation of these modes:

  • 2 Joystick uses the A channel to drive the left side of the robot, and the D channel to drive the right side of the robot
  • Left Stick uses A channel to drive forwards and backwards, and B channel to turn left or right.
  • Right Stick uses the D channel to drive forward and backwards, and C channel to turn left or right.

Press the X button on the Robot Brain to Exit the Configure menu, scroll up to Run, then press Check button to begin Driver Control program. Can you now use the 2 joystick channels corresponding to the selected Control mode (2 Joystick, Left Stick, Right Stick) to control motors 1 and 6?

If not, press the Down arrow button on the Robot Brain to see the Controller settings. When you move the joystick channels, do you see the values change from 0% up/down to 100% and -100% respectively? If not, you may need to follow the joystick calibration procedure. We have a Youtube tutorial video here: https://www.youtube.com/watch?v=5tMnivwgvsg

Regards,

  • Art

Thank you please can you advise when we the approx ET for the radio controllers is. I need to have it within 3 weeks to runt he course. What work around did the VEX IQs use at the exhibition in the UK ( Big Bang)?

By the way the VEX team have a GREAT display at the Big Bang and really bossed LEGO!!!

Thanks

Gabriel
handuvj.jpg

I have completed your tests and port 1 & 6 do not send signals. When I put right stick mode I got C operating and D partially operating.

Then I tried to re-calibrate the controller this did not change the values at all. They are all close to 127 127 127 and do not change.

Ummm stuck please help:(

Thanks

Gabriel

Hi Gabriel, quick question…we have had a VEXIQ for some time but have only just been sent the controller and radio chips. They came with a note saying that until the firmware is updated the radios won’t work but we can use Drive Control via Tethering…have you got tethering working at all.NB I note your problem with ports 1 & 6 which we have also had in the past - see some of my older posts! Interested to know if you have got tethering working? Oh, we are in the UK to and got the radios from Vex this week.

Andy

Ah, ports 1 & 6 are now working after plugging them in and out a few times - I think they are very sensitive to the cables being pushed fully home, and hearing the ‘click’! Tethering is now working too, which is good. Guess we just have to sit tight and wait for the firmware release for the 2.4 Ghz radio chips. Hopefully not too long a wait!

Hi Art, I do have to agree with Gabriel, the reliability of ports 1 & 6 is not good at the moment. For most of the day my brain and motors have worked fine…until for no reason port 6 has stopped working. I followed the procedure you gave Gabriel to monitor the ports and…values are showing against joystick values C & D so this is fine. However no RPM is registering against Motor 6 - the other motors do register! I know that the brain can see motor 6 because a)the VEXIQ Firmware update app is seeing all 4 motors (I’m testing against a basic claw bot) and when in the ‘run’ mode I cannot manually turn the motor as power is being applied - unlike when ‘run’ mode is stopped and you can easily turn the motors manually. This is still the same issue I was having at the end of last year…as we played with autonomous until the controllers arrived in the UK. I have re-callibrated etc…any ideas?

Andy

An update 30mins later, all is well again…ports 1 & 6 are working ok, which is all a bit odd really. I’ll update again of it repeats.

Andy

Andy,

We are sorry that you are having these problems. When you are running Driver Control program, a motor that cannot be easily turned by hand means the motor is working.

This is because the Driver Control program reads the values from the Controller, and uses these as a desired speed for the motor to run. If the joystick is centered, this is read as a commanded speed of 0rpm. This means the motor will fight any back driving forces to maintain 0rpm at the last commanded position. If the speed is shown as 0rpm even when the Controller joystick is moved from center, please press the Up/Down arrows again to view the Controller status screen on the Robot Brain. Is the specific joystick axis reading values that are not 0%? If this is still showing 0% and you have already tried calibrating the Controller, please contact our Technical Support at support@vex.com for more detailed assistance.

Please note we are very close to releasing updated firmware with 2.4 GHz Radio support for the Robot Brain to allow wireless operation. Unfortunately due to the nature of software development we cannot offer a more firm date.

Please note that in regards to motors not appearing connected to the Robot Brain, currently the Robot Brain only scans and initializes all connected devices when it is first powered on. If a device is unplugged or becomes disconnected or the I2C communications are interrupted while the Robot Brain is on, you must power cycle the Robot Brain for that device to be “visible” to the Robot Brain again. We are currently working on making this initialization process not require power cycles of the Robot Brain in the future.

For now, if a Smart Motor or Sensor repeatedly stops responding, please check.the following:

  1. Make sure the cable was not damaged and are fully inserted. Cables might become damaged if the cable gets stuck between two gears, or if the cable was pulled outward without the latch on the plug being pushed down. Swapping cables will help isolate this problem.

  2. Check the ports on the Robot Brain / Smart Device to see if they appear to be damaged or if there is any debris/dust inside them. This is a highly unlikely but possible source of intermittent connection issues.

Regards,

  • Art