Port 1 and 6 not responding

Out of the box I hooked up the two motors to the brick. One in port 1 and the other in port 6. Like it shows in the manual, a few steps before the clawbot is complete. I opened the default set up with the driver control and ran it. I noticed that port 6 was not responding. It was not the motor’s fault because any motor plugged into port 1 would work, but not when plugged into port 6.

I decided to upgrade all parts to the latest firmware, but now the problem has switched. Port 6 now works, but port 1 doesn’t. I haven’t been able to find a solution out of the manual or on the forum.

Hman,

We believe this is being caused by a setting under your “Configure” menu, please confirm with option you have selected under the *Control *of the Configure menu.
In order to access the *Configure *menu please follow this steps: Power on IQ Brain> select Driver Control> Select Configure

Let me know your results.

-Eli

I’ve experienced this before that when you plug in the two other motors for the claw bot it activates the ones in port 1 and 6, and at this moment they to stay that way even when you unplug the ones in port 10 and 11. But now the problem I’m having is when I push both joysticks forwards the robot goes back. Under the configure menu i have: Control: 2 Joystick Drive: Normal Motor 4,5,10,11:Normal Switching drive to reverse only help to drive straight forward but the turns are reversed

hman,

On Robot Brain firmware 1.07 and higher, we have added a new feature to the Driver Control > Configure Menu. The new firmware looks like this:

Control 2 Joystick
DriveTurn Normal
Drive FWD Normal
Motor 4 Normal
Motor 5 Normal
Motor 10 Normal
Motor 11 Normal

The two new options (DriveTurn and Drive FWD) have replaced the previous Drive setting to allow for all possible standard drive train configurations.

If your robot is correctly driving forwards, but turning left and right are opposite, change DriveTurn from Normal to Reverse.

If your robot is driving backwards, but turning left and right are correct, change Drive FWD from Normal to Reverse.

Regards,

  • Art