Port 1 of Brain Not Recognizing anything except Bumper Switch

Our robots Port 1 suddenly stopped working. We had the right motor for the Drive Train connected to this port. We initially thought it was the motor, but after swapping the motors, cables and ports we have identified that its the Port 1 of the brain that’s not detecting the motor or any other sensor. Same motor/sensor with the same cable is being detected on the other ports. Check firmware on VEXOS, everything is up to date.

Anybody else experienced this issue? Any suggestions? We have our qualifying tournament next week. Please help!

Thank you!

Did you try the Force Update Feature to see if it will figure it out? That has often worked for me.

Thanks for the response! How do I do that?

Has any one had ESD problems in IQ?


Put the motor in port 1.

Put your mouse pointer over the brain and right click, it should give you a menu to force the download.

I’ve had problems when the roboteers spin the motors and make a mess of one of the ports.

I’ve had good luck in forcing the reload and having it come back to life. I’ve found that the VIQ brains are pretty tough.

1 Like

I tried this and connected a motor, after reboot the motor is now being detected. Not sure what caused the problem, but its fixed for now! Thank you sho much for your help!! Really appreciate it!!

Is there a document that explains how the Robot brain ports are configured internally when driver control is selected? Like 1&6 or 7&12 are for drive train. Ports that are mirrored etc.

Thanks again!!

If you look at the Control Systems Manual that came with your robot it shows you the default connections on the brain. It will tell you that 1 and 7 are left side drive, 6 and 12 are right side drive 4 and 10 map to the front buttons and 5 and 11 map to the top buttons.

There are also bumper sensors you can plug into the the remaining ports to act as limit switches. The manual has all the details along with the demo program hookups.

I’m happy it all worked out for you!

1 Like

Thank you for all your help! It worked fine yesterday, but today when we tried to run the Autonomous program, the robot started acting up. Upon restarting we got the error: “I2C error detected on Motor Port 1-3 Reconnect Motor” and it stopped detecting the morot on port 1.

I tried to forced update again, but this time its not working! :thinking:

I’m going to guess that the motor is on the fine edge of dying. If you swap it to another port does the error follow it?

Could it be an issue with the tough sensor that we plugged into port 3. I removed it and rebooted the brain and now it detects the motor. We need the touch sensor for the autonomous portion.

If you move it does the issue follow? Replacing them is slightly cheaper than a motor : )

Yes, moved it to port 2, and as soon as I plug it in and reboot, the motor in port 1 is not detected. removed it and its detected again. I’ll get a replacement for that and test it.