Port Dying Causes Motor to Spin?

Hey forum!

Unfortunately, this happened a while ago, so we are not really looking for a solution at this point.

Sometime before states we had an issue where our drivetrain was driving while the program was not running. We had this issue again around states (I think it was the week before).

Here is a video of the issue.

For whatever reason, at some point (during driver practice if I recall correctly), one of the motors on the left side started constantly spinning. We spent a little time experimenting with it.

Our drive had 600 rpm cartridges in it.

Without a program running, when the robot was set down, the drive apparently did not have enough torque to move the robot. When we lifted that side of the drivetrain, it just spun indefinitely.

When we ran a program, the drive spun at approximately half the speed it was without the program running. When we used the joystick to go backward, the drivetrain went at full speed. When we used the joystick to go forward, the drivetrain stopped.

The issue persisted until we turned off the brain. At this point, the drive stopped running. When we turned the brain back on, the one of the ports that controlled one of the drive motors was dead. After switching the port, the drive performed as expected.

We surmised the following from this experience:
Somehow, the port dying had caused the motor to run constantly, even without any program running.
The single 600 rpm motor didn’t have enough torque to move the drivetrain, so when the robot was down, it didn’t move. When it was lifted, it could spin the wheels.
During the program, the second motor on the drivetrain was not spinning, so the extra friction caused the drive to run at a much slower speed. When we tried to go backward, the two motors working together in the same direction ran the drive at normal speed. When we tried to go forward, the two motors were fighting each other, but because they were 600 rpm, they didn’t have enough torque to cause any gear clicking.

We were very confused.

Since it’s been a while (because I didn’t write this post in a timely manner), I’m not asking for a solution. I’m just curious because I haven’t seen anyone else have this issue on the forum (I’m not on discord). Has anyone had this issue? Does anyone have a possible explanation?


Having killed a brain’s worth of ports myself, this is what happens when a port blows. The motor starts continuously spinning and doesn’t stop until the brain is shut down, or the motor is unplugged from the brain. As far as I can tell, there is no way to salvage the brain port when this happens. I have tried grounding the robot, unplugging the battery, unplugging the smart cord from the brain, and unplugging the smart cord from the motor.


We’ve had many ports die over the years, but I don’t usually find them to be continuously spinning. In case of other mechanisms, I thought I remembered them just dying. Maybe I missed something.

1 Like

I have seen this happen before, though most of the time when a port dies it doesn’t seem to do this. Perhaps this occurs if a port dies while the motor plugged into it is currently moving, or some other specific condition.


This most likely in my opinion. The motor receives a command from the brain to spin, but then the communication with the brain is severed when the RS485 transceiver is damaged by static, leaving the motor still powered but unable to receive any communication from the brain to stop.