Possible V5 Cotroller Problems


#1

I recently was messing around with the v5 controllers rumble function and i discovered that the controllers lcd screen would turn off the light, and flash red sort of like when it has low battery. I tried this code on a friends controller and it worked fine also this wouldn’t happen when the controller was plugged into my computer. The controller also did this when I used the built in “timed run” and “run competition”. I am using Pros and my whole v5 system has been updated to the latest firmware.


#2

this happened to me tooo SAME!!!

Does the run competition like the auto part work for you guys?


#3

auto part works but the controller just flashes red until I restart it


#4

oh for us it doesnt run the auto at all but it does blink red


#5

Can you share some code? Feel free to post here or DM it to me.


#6
if (flywheel_state == 1) {
    set_flywheel_power(110);
    if (fly_Top.get_actual_velocity() > 130) {
      switch (rumble_step) {
        case 0 :
        master.rumble("-");
        resetTimer();
        rumble_step++;
        break;
        case 1 :
        if (Time() > 501) {
          rumble_step = 0;
        }
        break;
      }
    }
  }

the documentation said to wait 50ms and I wait much longer than 50ms before sending the next rumble command.


#7

Is your controller fully charged? That would explain the red backlight.


#8

@edjubuh the controller was fully charged. I tried the same code on another teams controller and it worked fine. I also tried to use code from another team who used rumble and it worked fine on their controller but not on mine.


#9

Was this the same V5 Brain with just a different controller or different Brain and Controller? Either way, do you get different results when you run the program with the controller tethered?


#10

@edjubuh in all testing cases, my controller would flash the red screen. For some reason this doesn’t happen when the controller is plugged into my computer or when it is tethered to the v5 brain. @jpearman is there a way to fix this issue or should i get the controller replaced?


#11

If this is still happening after the controller has been connected to your PC or a USB charger with a good micro USB cable for a couple of hours, it does sound like the battery inside the controller is not charging and you should probably contact vex support,


#12

I have one controller that flashes red when rumble is used. Continues to flash until controller is rebooted. I have another with same code does not. Both have 1.0.3 FW and controllers are also confirmed updated.