Possibly bricked a Cortex

Was downloading a program using one of the older serial style wireless adaptors when the connection died halfway through the download.
The Cortex is now not recognised by EasyC for a download. I have tried reloading the firmware but the IFI firmware updater doesn’t recognise the Cortex either. Anyone experienced anything similar?

Connect the cortex (ie. connect the USB A-A cable to power it ) with the config button pressed in, see if the IFI update utility recognizes it then. It’s really hard to completely brick a cortex.

I did try that method earlier. Still not recognised.
Will give it another go tomorrow and see what I can come up with. In all the time I have been using VEX I have never bricked a Cortex but there is a first time for everything!

How old is this unit? Look on the bottom for the rev, A3, NC2 etc.

Try another PC, I’ve found that some USB ports on some PC’s just don’t work. A VM (ie. VMware or parallels) on a Mac almost never works to update master firmware.

The implication is that the bootloader and master firmware both got toasted. This should not be possible when downloading user code from EasyC etc. With all the development I’ve done over the years downloading really bad non-functional code (ie. early versions of ConVEX) I never managed to brick a cortex, however, it’s always possible that there was some type of external event (static shock etc.) that both aborted the download and caused some other damage.

Sorted this today. It was to do with the serial style wireless adaptor tying up a COM port and not releasing it once unplugged which meant the firmware updater couldn’t see the Cortex.