Power Expander Blinking Red

Hey everyone,
Last night I wired our robot and once I had finished I plugged in two batteries and powered the robot. For the first 30 seconds I used our old pragma to control various aspects of the robot with the wrong control (eg. When I pushed drive forward the I take would run). Anyways after this initial 30 seconds the robot power cycled itself and afterwards the power expanded would start to blink red. We tried replacing the battery three times but that still lead to the light immediately flashing red. We tried replacing the power expander twice but both both times it would immediately start to flash red. Does any one have any ideas as to why this is happening? We have tried everything we can think of and we just can’t figure out why this is happening. Thanks!

Are you getting the battery voltage from the power expander in your program?

We currently don’t have any voltage read out code implemented into our lcd yet.

@Anemeh18 Are you guessing we had dead batteries? We changed out the batteries a few times and the issue persisted. Or is there another problem you are alluding to?
Either way, thanks for your time.

Does the part that the power expander is powering still work? If it does it could be just you have an old power expander and the led or breaker is jacked up. The two expanders that you have tried how new arew they? And do you have anything connected in the monitoring port?

Power expanders just do this. Mine is an A2 and still gives me this even when nit reading from the status port. As long as the expander still works it should be fine, but you might need to keep a battery checker with you to be safe.

No, nothing powered through the power expander is working. Strangely, the problem persists even with a known working power expander and cortex.

In your situation it depends on how quickly the LED is blinking. Fast means the breaker was tripped and battery is very low, and slow means the breaker was tripped and battery is normal. Attached below is a table of power expander LED values and what they mean. This was pulled directly from the VEX website, and I’ve also posted that link below if you’re interested in reading it.

Power Expander documentation: http://content.vexrobotics.com/docs/instructions/276-2271-INST-0412.pdf
pwrexpander.png

There is no way the battery is low or that the breaker was tripped. With no load on the power expander (no wires in besides connecting to the cortex) the light begins to blink red after a few seconds. Low battery has been ruled out as well.

Disconnect everything from it, give it a fresh battery, plug it in.

Check battery cables for shorts and maybe open it up and have a check inside for shorts.

You may just have a dead power expander.

If you have the cortex off and then plug in the battery, what does it do?

Is the status port plugged into the cortex? If so, that causes the blinking.

In that case, this seems to be your explanation and solution.

@IrisDegree
What do you mean “VEX Robotics” can update the power expander?

This happened to me. The way I fixed it was I unplugged everything and then replaced all of the red, white, and black wires and then it worked fine afterwards.

There are two versions of the power expander. The original version was designed to work correctly with the older PIC processor, it had a minor issue when used with the cortex. New power expanders were revised to be more compatible. This change only affected the status port and LED, it did not have any effect on motor performance. This change was made several years ago.

See this (very) old thread for a few more details (mostly made before I understood what was going on).
https://vexforum.com/t/power-expander-status-port/20846/1

VEX can update old (pre rev A2) power expanders to the new spec (which only involves changing an internal component).

Thank you all for your help. It was much appreciated. We were able to fix the problem by installing a new batter extension and rewiring our robot.