Power Expander Problem [Urgent]

We have our reverse four bar lift connected to a power expander and for some reason it doesn’t work. The motors don’t turn. But when we connect it to the vortex directly it’s works fine. We tried changing the power expander and still no good luck. Any help please?

send pics of how the wires are done, you might have plugged stuff in wrong

Did you test it at all prior to this issue?

This year our team had a power expander for our drive (4 motor HS) and it kept stopping. we had know idea then we looked at the motors and they were warm. Then I later read that it was drawing too much power and tripping the power expander. Also is the light on when you plug the battery in?

Obviously annoying question: Did you connect the power expander battery? Does the LED Status indicator on the expander show stable green? (not blinking, not other color)

Have you properly wired IN (to the cortex, in the center of the expander) and OUT (to the motors, closer to the battery cable) ports?

Have you locked the “PWM lock” (the plastic slider over the whole expander body that makes sure the cables won’t detach)?

Are all your cables properly oriented (I know the cables are keyed. But the universe around us sometimes doesn’t care and we have had the same problem last week with cables plugged in wrong)

Reference: https://www.vexrobotics.com/276-2271.html

What does blinking green mean?

The internal PTC has been tripped.