Power Expander Problems [URGENT]

We have a power expander that we’ve used before and know it works (or at least worked), however when we put it on our new robot today, it does not work. We have 3 motors for our drive plugged in (ports 2-4) and 1 lift motor (port 6). None of these motors are working. The rest of the motors plugged into the cortex are working fine, both batteries plugged in are charged, the green light on the power expander is on and the motors work when plugged into the cortex. We have a competition in the morning and would appreciate any help. Thanks!

You probably wired it incorrectly, in/out wired reversed or black/white reversed, something like that. IIRC all the white wires should be next to each other on the inner side of the 3 pin connectors.

edit. I was wrong, white wires to center.

So we tried it and the wires would really only go in one way. Heres a picture for support. (YES WE KNOW WE ONLY HAVE ONE WIRE PLUGGED IN IN THE PICTURE)

Sorry is so huge…

You are correct, white wires to center, I should have checked.

Perhaps it’s just broken, do you have anyway to test the output (measure voltage between red and black wires) to see if the battery has been enabled for the output (there is an internal transistor that enables power to the output port).

No, we do not currently have anything to check the voltage. Is a multimeter the only way to check it?

However, does this just go bad? It has been sitting in our toolbox with the ports covered with tape for a month. It worked 100% then…

No it shouldn’t “just go bad”. Don’t know what to tell you, just bypass the power extender and run without it. We (team 8888 etc.) didn’t run any this year and things have been working just as well.

Ok thank you anyway!

Hello! My team last year used a power expander and it work very well. This year when we tried to use one the motors would freak out on us. An issue you could be having is how many wire extenders you have. The greater the distance you have the greater the chance for a connection to not function as well. The distance from the cortex to the expander made all the differences in our robot this year.

A way of checking it without an actual multimeter is to plug in the 2-wire motor directly to the power expander (where normally the red and black wires would go). However, this will make your motor constantly spinning in one direction at full speed and is not legal in a competition (but it’s a quick and easy way of testing your motors). If the LED lights up the transistor should have turned the power on the 3-Wire ports on (jpearman correct me if I am wrong :slight_smile: , I don’t have the schematics here).

Power for the internal pic micro controller and led comes prior to the output control FET. Schematic that I reverse engineered a while back here.

Jarred’s problem was probably just something simple and not a dead power expander.

You should also check anywhere you attach 3-wire extensions to each other or to a motor. These free-hanging connections don’t enforce the correct pin alignment and it is easy to get it backwards.

Make sure you connect them so that the wire colors line up (white-to-white, red-to-red, black-to-black). This means that the polarizing tabs will not line up, but that is expected.


  • Dean