Previous version of Vex Code blocks available?

How or where can we get the previous version of Vex Code Blocks to install? I believe it was version 1.0.4

We don’t want the current version 1.0.8 as it is causing issues to our previously working programs and would like to downgrade.

Can Anybody help? Or is it not appropriate to ask for an older version of the software?

We have no mechanism for providing older versions, what exactly is broken ?


This is from my post in another response in this forum describing our issues:

We had all kinds of issues after updating to the latest Vex Code blocks and the brain to latest OS. Since then, We had errors (Fatal Error 4) when downloading to the brain and only got around the errors after about the 8 or 9th brain restart. Other issues included the autonomous program making the robot spin in circles when it hit the line of code where the gyro was. Erasing the brain and reinstalling software didn’t work either. Our autonomous worked before the latest VCB but not after. And when opening our previously working program in the new VCB, it would get errors on compiling before it downloaded to the brain.

Not sure if the issues are in the brain OS or VCB, bu there are issues.

We are looking for a source to get the previous version of VCB to “downgrade”

PM me and I can provide a link to a previous version to test as I’d like to diagnose these issues.

Let me know what platform you’re running as well as we can only provide older versions for Windows / Mac.

1 Like

Message sent. Thanks

We are scrambling on a tight deadline as we have a competition this weekend.

So far what we have done:

  1. Use a different laptop to install older version of VCB - version 1.04 I think
  2. Did not install Vex OS Utility software.
  3. Swapped out the brain for one that had the previous OS (don’t know the version number but what ever was before the last version)

We were able to open our previously working autonomous program and download to brain. No issues when bot/program hit the gyro (no more spinning wildly). We were able to make edits and download to brain.

We had one old motor on drivetrain that was weaker than the other motor so we swapped it out with a new motor. I think the new motor we put in was actually a brand new one and maybe didn’t have updated firmware because after we connected the brain to the computer, VEX Code BLocks appeared to have automatically initiated download/install of the latest brain OS (2.14 I think). This happened before we realized what was taking so long to download the program to the brain. Keep in mind we still don’t have Vex OS utilities installed.

Now the brain has latest OS, working with older version of VCB. However…

We still get occasional errors when downloading to the brain - maybe 1 out of 4 tries it errors out.

blocks cannot do a vexos firmware update, you must have updated the brain in some other way.

1 Like

Something initiated the brain update. It was running behind the VCB window which is why we didn’t see it until the last few minutes. We did not manually update the brain. We didn’t want to in fact because of the issues mentioned above. We would have stopped it if we knew it was going to happen.

This was a windows 10 laptop that never had VCB or Vex OS utilities installed until we put just the older VCB on it.

Just to verify, you are using IQ ? (we are in an IQ category and you mention 2.1.4 which is IQ firmware)

VEXcode IQ blocks cannot update firmware, it will just prompt to download the vexos utility.

VEXcode V5 blocks can update firmware on the V5 brain.

1 Like

Yes IQ here.

Nothing was prompted to install Vex OS Utilities. It just did updated the brain on its own. Even after the update there is still no vex utilities on the laptop.

Just an update, we occasionally get fatal error 4 when starting the brain up, then the robot will just start moving on its own. We restart the brain it its ok again.

I’m asking the same question, for a slightly different reason.

Our students’ classroom laptops are administered by a single person in the school district IT section. He installed what was then the current version of VEXcode V5 on our machines. However, since that time the current version has been updated, and the existing laptops now won’t run teaching examples written on my personal computer (which is updated to the current VEXcode version).

How can I get an installer copy of the prior VEXcode version[s], so I can backdate my machine? Or, better, how can I get the student laptops to read code written with a later version? It’s not feasible to have the district IT guy come out and do a machine-by-machine update every time the version increments. (And no, they can’t push images remotely.)

Thank you!

What are the two versions of VEXcode you have ? code should be forwards/backwards compatible.

1 Like

My version is 2.3.0-113. The students’ version is 2.2.1-295.

The error message is “The project you are trying to open was saved with a newer version of the application. Please update your application to open this file.”