Print to Console not working

I followed the help topic and a video, both showed that the ‘print to console’ should be easy to implement. However, when trying to do so it is failing to print to the screen. It does work if I switch it to ‘Brain’ but fails if I set it back to ‘Console’. I also added a siren noise just to prove that it progresses through that step. It essentially ignores it though, as no print to console ever appears.

Just going off your screenshot, but it doesn’t appear like your USB cable is connected, which is the only way that I’m aware of that printing to console actually works (unless maybe you’re connected via USB into the remote, which is paired to the brain?).

Thank you for your reply. I did try it with the USB connected (just took the screenshot for this post later after it was disconnected). I have in the meantime tried it on both a Mac and a Chromebook. I have also started a new project, rebooted the robot and the machine - no luck.

are you using web based VEXcode ? I don’t think print console is supported there.


Yes, I was using web based VEX IQ. Just tried it within the app on my Chromebook and it worked. Thank you so much! We spent so much time trying to troubleshoot that. Appreciate your help!!!

You are able to use the console in the web version of VEXcode IQ, and V5/EXP as well. However, due to the way that the WebSerial interface works, you need to connect to the user port after connecting to the main serial port on the brain.

After connecting to the brain, you need to open the brain menu again, then click on the “Connect User” button and follow the prompts. After connecting, you will be able to see the console output as you would in the non-web versions of VEXcode.


We are planning to make this a little more clear in the brain menu dropdown, but I don’t know when that will end up happening.