Problem with Autodesk Inventor

when using Autodesk Inventor, it seems to me that I can’t connect the iMates of a bearing flat with any iMate of any structure. Can anyone come up with a solution?

I currently have Autodesk Inventor Professional 2017

Yeah… iMates can get really finicky, so I usually do one of two things (there may be a better way, but this is the best I’ve come up with):

  1. Most of the non-aluminum metal parts will have hidden circular extrusions in each of the holes. First, you’ll need to show these circular extrusions. Right click on your metal part and click Edit. Right-click on ExtrusionSrf1, ExtrusionSrf2, and ExtrusionSrf75 and click Visible in the left sidebar. Then, right-click on Rectangular Pattern1, 2, and 3 and click Show All Surfaces. Now you should see hollow cylinder-looking things in each hole of the part:

Click Return in the ribbon to go back to the assembly. Find your bearing and rotate your view so you can see the bottom holes (the holes you want to touch the metal) of the bearing. Click Constrain in the ribbon and choose Insert for the type. Select the circle (or part of it; it’s really the vertical axis that matters) on the bearing and then select the top part of one of the circular extrusions in a hole in the metal. Repeat this process for a second hole in the bearing so the bearing can’t rotate.
2. [Forewarning: I don’t recommend this method] This is complicated but will work for aluminum parts if you don’t want to manually add the circular extrusions (but if you want to do that and don’t know how, ask and I can tell you). Basically, use work planes to get an axis in the middle of the hole, and then constrain the vertical axis of a bearing hole to the axis you created with the work planes. This method is inefficient, time-consuming and creates a lot of extra work planes that you really don’t need, so I don’t recommend it.

I did the 1st one that you mentioned, however, this pop up showed up after i click show all surfaces

thank you for replying

It sounds like because you have your part files located in Content Center (and based on your current settings related to that), you can’t edit the part files.

The error message mentions that you have not checked out the file (are you using Autodesk Vault?), I believe I’ve seen a “Check Out” button on the My Home page in Inventor. So I would try opening the part file directly via My Home and seeing if you get an option to check out the file, which should let you edit it. Unfortunately, my team uses a system based off of Google Drive to sync our Inventor models, so I don’t really know much about your specific setup.

I did some googling and it sounds like this may be an issue with your project file settings. Basically, every assembly or part you create in Inventor has to have a project file associated with it that configures some general settings like the libraries you use and the paths of common parts files you use. So you need to edit your project settings to remove your parts folder from being designated as a library (instructions on how to do this).

What I do with the project is create a project that resides in the top folder of where the CAD models for my team are stored. Then, I added our parts library under Frequently Used Subfolders.

I’ve attached a screenshot of my project file for reference. The reason it’s a Vault project is not because we use Autodesk Vault, but because I am almost certain that if project type is Single User, you’ll get an error if you edit the project on a different computer because the username is typically part of the file path (unless you save the model somewhere where that’s not the case).

thank you for everything good sir. best of luck for your team, maybe we will meet someday.

That depends… what state is your team in? What’s your team number?