Problem with Intelitek Loader 3.1

I just upgraded my installation of EasyC Pro from to, and all seemed to go well except that I can no longer access the programmer.

Every time I try to bring up the Terminal, On-Line Window, or download a binary, I get a “Failed to Initialize On-Line!” message. All the com ports are grayed-out and none are checked, so I can’t select COM5 (where my programmer should be). I tried uninstalling and reinstalling (and rebooting) a couple times but had the same result. This is using the Intelitek loader v3.1.

I tried running EasyC V2 and it sees my programmer on COM5 just fine, so I don’t think there is a problem with the serial driver. I noticed that was using Intelitek loader v2.9.

I will try downgrading to EasyC Pro next to see if that helps.


  • Dean

OK, I’ve gone back and forth several times now. ECPro always lets me select COM5 and sees my programmer. ECPro never lets me select a COM port.

Please let me know if there is a workaround, or if you need additional info to sort this out. In the mean time I’ll just stick with the older version.

Oh, I should add that I’m running this on Windows Vista Ultimate + SP1.


  • Dean

You need to goto LoaderSetup under the Build and Download menu. You can also select “automatic” and the loader will hunt for the programming cable com port.

Yep - that was easy. Thanks!

The reason I went looking for the upgrade in the first place was that I was unable to run I/O Ports 1-10 as digital outputs under program control. I’m happy to report that the upgrade fixed that!


  • Dean