Problem with uploading code

When I was trying to upload some code to the V5 brain it wouldn’t update the code. When I tried to do it through the controller it said it downloaded the code on my computer but it didn’t change the code on the brain. I tried hard resetting the controller and unplugging the brain from the battery but the problem still occurred. I’m assuming it’s the brain because when I plugged the controller into a different brain it downloaded code just fine. I was hoping someone could help with determining the cause of the problem and how to fix. Also tell me if I forgot to say something.

Edit: It works again but I’m still curious why it broke in the first place. Doesn’t make any sense.

Are you by any chance running the program on a mac, and using vex coding studio?

My issue When Using vex v5 Studio Is it required to have internet So check that

Windows 10 with normal text

Try To Check the vex library

This doesn’t exactly tell us what software you use to program.

Vexcode text?

I’m using vexcode text and I was offline while using it but that’s never been a problem before