Problems pairing new controller

I’ve recently bought a new controller to replace a damaged one, but I cannot get the wireless function to work.
I’ve gone through the pairing procedure as outlined in the book, but although I can control the robot while tethered, once I disconnect the cable the controller powers off and I can’t connect it wirelessly. It will still connect with the old controller.
Any ideas?

When you disconnect the cable from the robot, does the contoller power stay off? Is it able to turn on without out the cable?

If it won’t stay on, we had a similar issue this weekend. One of our students dropped the controller and it wouldn’t power up unless connected to the robot by Ethernet. We fixed it by taking out the battery and putting the same battery back in. Then the power stayed on and it was able to connect wirelessly. Seems that when the student dropped the controller, it unseated the batter from connecting.
Vex Video Overlay Instructions.pdf (57.2 KB)

Is the radio module pushed all the way in? Have a look at this excellent link from Kiwibots:

When I disconnect the tether cable the power on the controller goes off.
Thanks for the link, I’ll try to fiddle with the modules and make sure it’s in all the way. However on that link it says if you can see the gold pins you should stop and contact them. I can see the pins on one controller, it looks like the plastic cover has stuck in the radio module.

Well, I’ve checked the radio modules and it does look like the plastic cover has come off and the pins have been squashed a bit. I’ve managed to get the plastic cover out from the radio module, but as the pins have been squashed I don’t think I’m going to be able to get it back in the controller. I’ve tried to straighten them, but it’s very fiddly. So that’s frustrating.
But I also have another controller that as far as I can tell, the radio module is in properly, but I still can’t get this to pair with the brain. I can use it tethered but as soon as I disconnect the tether the power on the controller goes off and I can’t get it to turn on again.

If the power to the controller just goes off as soon as you disconnect the tether cable despite it being on charge previously, it will probably be a duff controller battery and can be replaced. How old are the controller batteries?

Yeah, it looks like you’re right. I just tried swapping out the batteries for one in a controller that does work, and it does connect. The batteries are about 2 years old. It’s frustrating as it seems two batteries have died over the summer holidays. I now have 4 controllers and only one is usable! Also I’ve got a brain battery that will not charge either, again it’s about 2 years old.
Looks like I’ll need to get some more batteries.
Thanks for the help.

Brain battery can most likely be recovered but the controller battery probably not…Will send you a direct message.