Problems uploading with PROS

Every time I build and upload a program with pros, the program ends up “not” uploading. The upload goes through, but none of the changes that I make go through. It also returns this error, even though no VEX-related application (VCS, VEXcode, etc) are open.
serial.serialutil.SerialException: could not open port 'COM6' : PermissionError(13, 'Access is Denied.', None, 5)
When it finishes uploading, the program runs the first version of the program. Any subsequent changes don’t go through.

Also, when I try the wireless uploading, it doesn’t detect the V5 port.

The error means, for some reason or another, your operating system is not allowing PROS to communicate with your Brain.

What operating system are you using?

I’m using Windows 10.

The port is most likely already being used by another process… Are you sure (VCS, VEXcode, etc) aren’t running in the background or something? You could try uninstalling (VCS, VEXcode, etc); also maybe try reinstalling pros drivers?

1 Like

How do I reinstall the drivers? Do I have to uninstall and reinstall PROS completely?

Nevermind I found this

OK, so I tried uninstalling and reinstalling pros, and the problem is still happening. I don’t get the COM6 error anymore, but it’s still not uploading any changes I make from the default code when you make a new project. Anyone else have other suggestions?

EDIT: I’ve also tried clean building, deleting all programs and then re-uploading. It still doesn’t work.

@edjubuh @hotel


Have you reboot your computer?

Yes. I’ve tried reinstalling and rebooting.

What happens if you try to connect to the Brain with another application, like PuTTY? Does it connect successfully or error out?

If the answer is unclear, try uploading code from another computer that will repeatedly print something to the serial terminal. Then, see if PuTTY will read those messages.

1 Like

Are you sure that it compiled without any errors.

There was a warning about “unknown attribute optimize ignored” in adiGyro.hpp but that was about it.

The error clearly concerns communicating with the V5 Brain to upload code. Whether there is a compiler error or not is irrelevant (though PROS would not get to the upload stage to generate the serial port error if there was a compiling error).

I haven’t tried PuTTY yet but both VEXcode and VCS are able to detect and upload to the brain just fine.

Don’t think it was mentioned before in this thread, but have you tried using a different port.

Ok so I think I found the solution, and it’s probably just a beginner mistake that I made:

  1. When I make a new program file, immediately build clean and then build all.
  2. Save changes in files before building/uploading.

I made a new program file following those and it uploaded changes just fine.

That’s weird, my team didn’t have to do that.

In my experience this is not true. I usually run prosv5 mu, and there have been many times where compilation has failed but the binary from the previous build was still uploaded.

Well, at least in theory, that’s how it’s supposed to work as far as I know. It seemed to work that way in PROS 2.