Problems with connectivity to controller

I recently pulled out my programming kit and found that the usb-serial kit that came with it and the cable from the interface device were missing.

I purchased a usb-serial adapter and assigned it to com3, I also made a 6 wire straight cable, and a 6 wire rollover cable.

using the usb adapter connected to interface connected to 6 wire straight cable i can get controller verification, but can not download the master code. I get the “make sure the power is on and the serial cable connected” message.

can anyone offer assistance?

i know most ppl dont like going back to manufacturer and rather fix it but you should notify First which im pretty sure is the manu.

What you tried will not work.

The little orange box contains a voltage level-shifter to convert the microcontroller’s 5 Volt signals to/from the USB-to-serial cable’s 12 Volt signals.

Your simple cables don’t do the voltage conversions. I hope you didn’t ruin the microcontroller’s interface circuits.

The little box also does just a little bit of signal clean-up and or signal generation because many USB-to-Serial cables corrupt the timing of the signals they convert.


right, and I knew that, I never directly connected anything to my controller, the orange box was always in the loop.

what i have is a usb-serial adapter coming out of my pc into the orange box then to a straight 6 wire cable into the controller.

using the easyC program, under the downloads screen if i click controller verification it comes back and tells me i have a vex connected, if i turn the vex off it no longer sees anything connected, so i know I’m close.

I believe the issue is in my straight cable, im not convinced it is supposed to be straight, but I dont know.

so your just missing the 6-pin serial cable??

I’m pretty sure that an ordinary telephone (wall-to-telephone-base-unit) cord is all you need to use for that part of the connection.

By searching this site or the Chief delphi site you should be able to find pinouts. I’m pretty sure I recall seeing them posted here or there.


thank you for the assist. I have searched this site and Ihave fouond the pinouts for different items, but nothing to state exactly what kind of cable this is.

is it a straight cable wire for wire on both sides?

a standard phone cable is not a straight cable, its generally a ‘roll over’ cable, but more importantly to this project, a standard phone cable is usually a 4 pin cable.

the cable needed is a 6 wire cable, a rj-11 (vs. ethernet which is rj-45 (8 wire)). I work in the telco - IT field, I make cables every day, have my own crimping tools, etc. I just need to know what kind of cable this is, because a roll over cable did not work at all, and a straight cable only gave me controller verification so far, and would not let me download the master file.

in the morning I am going to simply try swapping rx and tx wires on one side of the cable to see if thats my issue. I hope someone spots this post and can tell me what cable they have.

What i need to know most is if the wires are the same on both sides?

Thank you

I did not investigate, the wiring of the connectors… I just went to some inexpensive store and bought a “Phone Cord”.

I am away from home, so I can’t ohm out the cable or do other investigation for you - Sorry about that - We are working off of my recollections from about 9 months ago.

after some more researching on this site I think my problem is more related to the pgrm status light, which is not turning on, but once and awhile starts blinking once every 5-10 seconds. I havent figured out the what and why of that yet.

I don’t know if you know this but pressing the orange button on the serial adapter is supposed to send the robot in “program mode”, when it’s in this mode I believe the green light is blinking. When the robot is executing code I believe the green light is solid.

yes, I have tried pressing the button on the orange interface box, and it appears to do nothing for me so far. thank you for the suggestion.