Problems with Encoder Modules. Help!!!!!

Our team has installed the new encoder modules onto our drive train motors. we were very excited until we didn’t get any encoder signal. our encoder just reads zero. we have the encoder connected to the I2C port on the cortex just like the instructions call form. we use Robot C and have followed to a T the setup for the motor and the attached encoder. However when we run the the motors the encoders do not change from a value of zero. Any insight would be greatly appreciated.

Carefully re-check all the cables. When I was setting up my encoders, I had some problems with cables being plugged in wrong or not at all.

That’s where I ended my day. Checking cables. We even reduced it to only one encoder on one motor to eliminate daisy chain. still no luck.

What version of ROBOTC ? Version 3.08 or later required, I would go for the latest if you have not upgraded yet, 3.54 (Nov 2012).

What color is the LED on the back of the IME? It should flash occasionally green (twice for the last IME) if they are initialized correctly.

Which IME? 269 or 393?

Did you install the black and white encoded gear correctly? I heard of one situation where the wrong one was exchanged.

Have you indicated in the motors & sensors setup that the motor is encoded and the correct type of motor?

And finally, check the cables again, check the key is correctly aligned and that you did not bend any pins on the IME’s connector.

Have you tested each encoder singly ? if neither works by itself I would ensure they were assembled correctly with the black and white gear in the correct location (it should be the last gear back into the motor).

We had one encoder out of about 10 purchased which was non functional out of the box. Although it initialized correctly we never got data from it and sent it back for an exchange, but the other encoder packed with it worked fine. the replacement encoder from Vex worked fine.

If you’ve checked everything James mentioned and still getting no readings you should probably contact Vex technical support.

Cheers Kb

Checked one encoder this morning and yes, my student didn’t install the gear at all. Now that encoder works fine. The other two will require a bit more disassembly to check. Sounds like an after school project. I’ll keep you posted.

Any other suggestions?