Problems with Programming

Our students are using the “Graphical ROBOTC for Robotics 4.X” program on a PC. One team is having trouble in particular, even with seemingly simple a program/commands. First they tried this:

  1. forward (1, rotations, 50)
  2. turnRight (1, rotations, 50)
  3. forward (1, rotations, 50)

The robot would move forward, turn right, and then stop (no idea why it doesn’t go forward like the 3rd line of programming shows.) I had them change the turnRight command to a turnLeft command; the robot turned left, but much further than a 90 degree angle. We tried changing to "turnLeft (1, rotations, 5-40.) No matter which number we used, it always overturned to the same point. They tried changing to 90 degrees (instead of rotations) and had the same problem with the same angle.

We aren’t sure what’s happening. The robot and all components are up to date. Any recommendations or advice? Thank you.

Hello Jon,

We apologize for the delay. There are only a couple possibilities that would cause the program to stop prior to line 3:

  1. The robot can’t complete the previous line. It’s important to note that the third parameter for these commands simply changes the power. The amount of turn is determined by the first and second parameters. To expand, a single rotation will turn much further then 90 degrees. It’s also important to note, when changing the second parameter to ‘degrees’ from rotations, these only changes the amount of degrees the motors themselves will turn, not the amount the robot will turn.

  2. Issue with the code/firmware. I recommend reinstalling the firmware (both VEX and ROBOTC) and attempting to run a sample program to test the code. Also, try attempting the same code on a different robot or the same robot and a different computer to further rule out possible problems.

The free online curricula found at would also be a great place to start. Feel free to check out the free video tutorials offered within.