Program Wiping Off and Not Downloading

About a week ago, we were at competition with our Vex robot. At the end of the competition, I took the Vex bot to the practice field to test the program and then brought it, almost immediately, to the playing field. I put it on the playing field and the yellow program light (not the green one) was not turning on (generally, this light turns on when I turn the robot on); from what I could seen, the program had been spontaneously wiped off the robot.

I had been having that problem with the robot for the next couple of days (where programs would get spontaneously erased from it). As of two days ago, I cannot even download programs onto my robot. Whenever I try to download, it fluctuates between “COM port open” and “No connection” for a few seconds, and then tells me to check my power supply and connection. I am using a fully charged battery, and I’m quite sure that the USB connection is strong. In addition, I have tried downloading a wide variety of codes onto the bot, from codes I have used in the past (including an RC code), to the default and master codes, to simple programs that turn one motor on. None of them work.

I read another post saying that this problem could be solved by letting the computer sit overnight and trying again; this did not work for me.

Basically, now I have a robot with no code on it whatsoever. The green power light and the green program status light (next to the power light) are both on, but that’s it. Sometimes, when I try to download programs, the motors turn on and off inexplicably; other than that, it does nothing!

Does anyone know what could be going wrong here, with the robot not being able to download programs and wiping them off spontaneously?

Thank you so much!!

man is there like microwave coming from all the cell phones or something that is destorying everyone’s microcontroller? this is like the 2nd or 3rd post i saw this WEEK about a broken microcontroller!

being serious this time…
how many times have you programed your microcontroller? on the Microcontroller information it says it can be programmed/erased for100,000 cycles, which i’m sure you haven’t done already… could it just be a shorting motor or sensor? if it isn’t, sounds like your microcontroller memory is toast

Thanks for responding!

I think that it is highly unlikely that multiple motor/sensors all shorted at the same time (I tried more than one)–also the fact that the yellow program ready light wasn’t turning on concerns me (it wasn’t responding to a program on it).

Is there any way to fix the microcontroller in this situation?

only 1 motor/sensor needs to short to mess up the program/performance. limit and bumper sensors can’t short because they don’t draw power. As to the yellow programming light, i didn’t know there was one. i thought they was only green and red; i have had the red programming light come on because i forgot to add a variable, but with the variety of codes you tried eleiminates that possibility. I think your microcontroller is just broken. do you smell an odor when you turn it on? an odor could be the sign of a short.

Did you check out Program Light Stuck On? Not sure if that might help but you mentioned it was on.

That is somewhat like the problem I’m having; thank you for showing me the link! Unfortunately, that’s not really working…

Oh…But I tried an RC program too, so that shouldn’t be messed up with one short, right?

The yellow light I’m referring to is the one above the program status light and the battery light–it’s on the top edge of the front face of the robot, and, in my experience, it usually turns/flashes when the bot is trying to execute a program.


i guess you should just take it apart and figure out if a wire came loose or something. it may be touching another contact and messing it up. If it’s still under warrenty, send it back.