Programming Issues


My students are trying to program our robots and we have updated our firmware and tried to download from EasyC 5. Except, when we turn on the cortex, the wheels spin and will not stop. We have tried to change the location of the motors on the cortex, download a program that does work, change batteries, but the robot wheels will not stop turning. Help :slight_smile:


Hi munsoni,

We are very sorry for the delayed response. Are you still having this problem?

If so, there are a few questions that can help debug your robot.

Are your motors plugged directly into the Cortex, or are you using a Motor Controller 29? Motor Controller 29s are needed for any 393 Motor plugged into Ports 2-9 on the Cortex. Motors will receive power from the Cortex if they are plugged directly into Ports 2-9, but there will be no control over them. 393 Motors plugged into Ports 1 or 10 are controlled by a speed controller inside the Cortex, which is why a Motor Controller 29 is not necessary for these ports.

Have you tried downloading Default Code? Default Code is an excellent way of testing whether this is a User Program bug or if there is a problem with the electrical system. Testing with a known User Program is a good idea, but Default Code is a very well known working program that can always be downloaded to test with whenever the robot acts unexpectedly.

Hope this helps. If you are still have difficulties, please post back here with pictures of your Cortex and other electronics and we will continue digging deeper.