PROS CLI issues

Running the pros command in cmd gives me the following error:

Python path configuration:
  PYTHONHOME = (not set)
  PYTHONPATH = (not set)
  program name = 'C:\Program Files\PROS\cli\pros.exe'
  isolated = 0
  environment = 0
  user site = 1
  import site = 0
  sys._base_executable = 'C:\\Program Files\\PROS\\cli\\pros.exe'
  sys.base_prefix = ''
  sys.base_exec_prefix = ''
  sys.platlibdir = 'lib'
  sys.executable = 'C:\\Program Files\\PROS\\cli\\pros.exe'
  sys.prefix = ''
  sys.exec_prefix = ''
  sys.path = [
    'C:\\Program Files\\PROS\\cli\\lib\\library.zip',
    'C:\\Program Files\\PROS\\cli\\lib',
  ]
Fatal Python error: init_fs_encoding: failed to get the Python codec of the filesystem encoding
Python runtime state: core initialized
ModuleNotFoundError: No module named 'encodings'

Current thread 0x00003d60 (most recent call first):
<no Python frame>

Reinstalling PROS from the vscode addon and using the setup wizard gives the same results.

1 Like

Looks like you need to reinstall Python. Go ahead and download it from the python website (python.org), and you should be sweet.

If that doesnā€™t solve it, can you please try running ā€œpip install encodingsā€ in the command line?

Unfortunately, neither of those things made a difference, but thanks anyway. I also tried downgrading to python 2.6.3 but that didnā€™t do anything either. Not sure if python is the root cause here. Any other suggestions?

Which version of the cli did you try to install? Additionally, you said that the vscode extension install gave you the same error: 1) Did you run the pros command in the integrated terminal (accessible by clicking the ā€œIntegrated Terminalā€ button in the PROS sidebar)? 2) if you did do 1, was the error message EXACTLY the same? If so, then you need to uninstall the first PROS install before doing the vscode install. Please keep in mind that the vscode install will NOT install the cli for use on your entire system, it will only install it for use within vscode.

I installed the one that automatically came up on the vscode extension. Then I tried using the v3.3.3 installer. Same exact error in ā€˜integrated terminalā€™ and in normal cmd/powershell. Uninstalling the system-wide cli and vscode extension now.

This looks like a python issue (according to python - ImportError: No module named 'encodings' - Stack Overflow). Try some of the things on this website. I cannot guarantee anything though since I have never encountered this issue.