Pros CLI not working

I am trying to build my project in PROS but it gives me this error: /Users/[username]/Library/Application Support/Code/User/globalStorage/sigbots.pros/install/pros-toolchain-macos/bin/…/lib/gcc/arm-none-eabi/10.3.1/…/…/…/…/arm-none-eabi/bin/ld: error: firmware/okapilib.a: file too short

ERROR - - Failed to make project: Exit Code 2 - pros-cli version:3.4.3

make: *** [bin/cold.package.elf] Error 1

PROS-CLI Version: 3.4.3

PROS-Kernel Version: 3.8.0

Error: Failed to build

Sentry is attempting to send 1 pending events

Waiting up to 2 seconds

Press Ctrl-C to quit

I have tried reinstalling the CLI with homebrew and normally and installing pros through the software again but nothing is working. Does anyone know what the problem could be?

Also it says that the CLI is working but its still not able to build… (also I made this project like a week ago so its not that)

Did you modify the okapilib.a file? If you aren’t using okapilib, try running the command pros c uninstall okapilib and then pros make clean and then pros make.


I will try that, but I do plan on eventually using okapilib, so how do I use it with okapi?

Ok I just tried that but nothing happened, it did say “okapilib@>=0 (BaseTemplate) is not an applicable template
Cleaning project” though (also I am using c++ if that helps)

Does this same bug happen if you create a new project? I’ve honestly never seen this issue, but it looks like something went wrong with the okapilib template that comes default on the project. Hopefully creating a new project will fix it.


Thank you, that worked, I have no idea what happened but I think I might have accidentally messed up some settings idk.