PROS code not uploading

I’m new to PROS, and I had a test program that I wanted to upload to a chassis I built to practice and make sure I was doing everything properly. When I pressed ‘Upload’, I got an error message saying: “ERROR - pros.cli.common:resolve_v5_port - No v5 ports were found! If you think you have a v5 plugged in, run this command again with the --debug flag”. This was despite both my controller and robot being on. If anyone could help I’d greatly appreciate it. I’m not sure how much this changes but I’m running on Windows 10

Have you check to make sure that the micro-usb cable is fully plugged in to both your computer and the brain?


yes. both ends of the cable are firmly in the ports. The cables that I’m using have been very reliable to me throughout last season. I went on my parent’s laptop as well and it also could not detect the v5 brain (I was using the v5 firmware utility).

You mentioned both the robot and controller being on. Were you trying to upload through the controller? If so, PROS requires you to edit some settings in the Makefile before you can use wireless uploading (See

In addition, if possible try uploading through the command line with the --debug flag (I believe Atom has a built in terminal, so just run prosv5 upload --debug) and paste the results here.


At first I was trying to upload through the controller, but I also tried uploading through the brain after reading about this on their website. In regards to what you said about the terminal, I’ve tried doing that but whenever I open up the terminal I can’t even write anything before it tries to build (where it says that no v5 ports were found) or it skips right to saying that no v5 ports were found and closes itself. Do you know anything about why I can’t type in the terminal?

I’d guess you’re typing in the PROS terminal rather than in a command line prompt. Are you on Windows or Mac OS?

If you’re on windows, go ahead and connect everything up and open up a cmd window. Navigate to the directory that your PROS project is in. type prosv5 lsusb. Based on what you’ve told us, This will confirm that you have no ports plugged in. If that is the case, go ahead and open up Device Manager and see if your machine’s COM ports are registering anything. If neither of these suggest that your machine has recognized a new USB device, check to make sure that your USB cable is capable of data transfer (if it’s the one that came with your V5 brain then it will be, but there are a lot of USB cables out there made just for charging devices that are actually not capable of data transfer).

If you’re on Mac, do the same thing, but with the terminal and system preferences to find what USB devices have been recognized.

If none of these things seem to suggest where the problem is at, see if perhaps there are drivers missing from your install of PROS. Run the setup wizard’s repair function and see if that detects and/or fixes any problems.

If any of the above steps give you a more specific error message, copy paste the message into here so we can know a bit more about the situation.

Edit: Sorry I realized you addressed what operating system and cable you’re using earlier.


Sorry it’s taken me so long to respond to this but in the meantime I tried out a bunch of things. I tried what you said about typing prosv5 lsusb. It said:

There are no connected VEX EDR V5 System Ports
There are no connected VEX EDR V5 User Ports
There are no connected VEX EDR Cortex Microcontroller Ports

PROS seems to be working fine. I ran the setup wizard and it didn’t find anything. Additionally, I also copied my code over to VEXcode with tweaks for proper syntax and it too couldn’t detect the brain. I thought that maybe the USB port on the brain was broken, so I plugged my cable through my controller which was connected to the brain and it still didn’t detect anything.

I also checked the brain to see if it detected any connection by going to Devices > Brain on the V5 Brain. It also said that the USB connection was ‘Unplugged’.

As for the device manager part, my laptop didn’t detect any connection either. I tried multiple cables that all supported data transfer as they were the ones my team used all year. None of them could provide a connection between the brain and my laptop.

If you have any advice I would greatly appreciate it. Thanks.

Edit: I forgot to add this but I just remembered. My brain is on VEXos 1.0.8. The current verison as you probably know is VEXos 1.1.0. Maybe this is the problem, I’m not sure. If it is, I’m not sure how I could fix it as the brain simply cannot connect to anything and therefore I cannot update it.

Have you tried another cable? Micro-usb cables aren’t particularily atrong.

1 Like

If windows doesn’t detect the V5 brain in the device manager, it sounds like you have a brain with a broken USB port. Test the cable with the controller, see if that shows up in device manager. But everything you are describing (the test on your parents laptop, test with multiple cables, no sign of the V5 in the device manager) suggests a broken V5 USB port.


I’ve tried multiple. The ones I tried have always been successful to me in the past. I used them during tower takeover and they always connected immediately with success.

I agree, I feel like the USB port on the brain is likely broken. But when I tried to find my controller on the device manager, I couldn’t find it either. I’m not sure how to tackle this situation.

If you still haven’t gotten it working and it seems likely to be a bad USB port. I’d change cables and ports on your laptop and plug in your controller making sure that both the brain and controller are freshly rebooted and try that. Also make sure that other usb devices are working on the laptop.