PROS cross compiler refuses to work

I got prose-lite install but it seems that the cross compiler just will not work.

username@darkstar ~/M/C/P/vexStarstruck> make
CC -I../include -I../src opcontrol.c
make[1]: arm-none-eabi-gcc: Command not found
make[1]: *** ../bin/opcontrol.o] Error 127
make: *** [src] Error 2
username@darkstar ~/M/C/P/vexStarstruck> 

the toolchain is in my PATH variable. Interestingly, I’m running slackware which with a full install (which is what I did) comes with arm-none-eabi-gcc installed in /usr/bin. when I run

arm-none-eabi-gcc -v

I get:

Failed to execute process '/usr/bin/arm-none-eabi-gcc'. Reason:
The file '/usr/bin/arm-none-eabi-gcc' does not exist or could not be executed.

and if cd into /opt/pros/pros-toolchain/bin/ and run

./arm-none-eabi-gcc -v

the same thing happens. any clue on what the issue is?

I can’t remember exactly… you’re using Proteus or Slackware?

I was using Proteus now I’m on Slackware.

update: tried this: still not working. I have a friend who is going to help me build the toolchain myself so hopefully that will work.

so after 4 or 5 attempts, help from a freind, and some lost sleep I finally managed to build the arm-none-eabi toolchain. If anyone else has trouble with their toolchain pm me and I’ll send you a shell script that will build it for you.

Glad you finally got it working! If you want to host those pre-compiled binaries somewhere, when we do the next release of PROS we can link them in for Slackware.

uploading now :wink:!bNo1wBhI!f3_JnNs5MJPDUK1hJc1MTg

EDIT: now uploaded