PROS Download Problem - No Vex Cortex

Hello Forum!!
I’m new to programming as well as being on a robotics team itself (the school I went to last year had a really bad team). I’m the programmer for my team (not new to programming at all, I know 12 languages). I’m having trouble with downloading PROS itself… when I download it, the installer installs the java, the ide, eclipse, etc., but when I open the PROS IDE up, I don’t get an option for VEX Cortex or a tab for VEX. It doesn’t show up in the perspective either and I tried redownloading the drives, java, PROS itself, and nothings gotten it to show up. Does anyone know what’s going on/can help me?

Thanks in advance!!!

EDIT: I also keep getting this error when PROS opens up: The environment variable HOME is not set. The following directory will be used for storing the Git user configuration as default repository location C:\Users\Name. If this is not correct please set the HOME environment variable and restart Eclipse.

Not sure if this helps, but I thought I’d put it up.

Not sure about it not opening PROS, but the error message about Git (almost certainly) has nothing to do with your problem, that’s a standard error message I got every time I started PROS up before I set Git up properly. Sorry I can’t be of more help, just wanted to make sure you don’t waste time trying to fix an unrelated issue that’s not actually really even an issue.

I too am having this issue, on one of the computers I installed PROS on the installation was seamless and had no problems, on the other the vex/pros perspective would not show up!

Even in the offical PROS THREAD this issue was looked at and yet no solution was found (at least from what I can see).

You can safely ignore the error message about git, although you can use git with PROS. PROS will work completely fine without it!

Hey guys I am jumping on this thread to acknowledge the issue and that it is a known one. Class is now in session at Purdue and I am happy to say that I recruited a couple new members to help with this issue specifically.

On another note the eclipse plugin code where this issue resides is open source (link to code) and anyone is free to take a look as well.

I’m having this issue as well, and because of it I can’t switch from ROBOTC to PROS.
Glad to hear it’s being resolved!

We have a temporary workaround for this issue. You can view it here. An updated release of the PROS environment will come within the next couple weeks that does not have this bug.

I played around with the setup some time ago and managed to bring back the VEX Cortex tabs.

It seems that the tabs only go missing when you have JRE 8. As soon as I uninstalled that and went back to JRE 7, everything worked fine.

Also, having both JREs on your computer seemed to bring back the problem, so make sure to have only JRE 7.

By the way, I’m on PROS 2b09. Not sure how this fix’ll turn out with other versions.


We’re in the process of working on a new version of the PROS IDE. At the moment, the IDE itself is ready to go. The plugins require JRE 8 - nothing lower, and they’ve passed testing.

I always appreciated knowing what’s going on with the development of some software, so here’s an update: Unfortunately, with some tweaks to the way the toolchain works now, there are breaking changes in the way Eclipse looks at the project and its configuration - meaning we need an upgrade process. I’ve worked on that over winter break (the new upgrade process is more robust and extensible), and I’m working on interfacing Eclipse with that upgrade program right now (presently, you’d have to do it all via command line!). Our goal is to have as little overhead in the future when we do upgrades and streamlining that task (especially tackling Eclipse) takes some time to develop and test all those components.