PROS Error on Project Creation

Hello,
I just installed PROS on my Desktop iMac using Homebrew. Everything seemed to install Okay from the Terminal, and when I first opened up the App it looked fine. However when I tried to create a new project it popped up with the following error:
58 AM
If anyone could give me any suggestions, that would be great.

I’m not sure what the problem is. To provide the pros devs a better error message, can you run prosv5 --version in your computer’s terminal and paste the whole error here?

3 Likes

I ran the suggested command and got this:
Traceback (most recent call last): File "/usr/local/bin/prosv5", line 6, in <module> from pkg_resources import load_entry_point ImportError: cannot import name 'load_entry_point' from 'pkg_resources' (unknown location)
Hope it helps:)

It looks to me like PROS cli can’t find a file called pkg-resources.py. I would just uninstall and reinstall PROS.

Yeah, I would try to reinstall and follow the steps very closely. If that does not work, hopefully a pros dev can help you.

2 Likes

I had a similar problem myself, and my solution was simply to reinstall pros.

1 Like

I’m having a similar issue as well. I get this error when I attempt to create a new project from the PROS menu:

image

This is the output from “prosv5 --version”:
pros, version 3.0.7

I’m running PROS on a Mac. I tried reinstalling but got same issue. Any help getting past this would be appreciated!

Try updating your cli. The current version is 3.1.4

1 Like

I used Homebrew for install, but I’ll try the other option for installing CLI separately.

Late response but it looks to me as though you have an old version of the CLI installed that’s taking priority over the homebrew one.

Can you share the output of which prosv5?

2 Likes