PROS Not Uploading to Brain

Hi, I am new to PROS and just started testing uploading code to the brain. When I build the project and upload it, the message(in image below) pops up but nothing transfers to the brain. Does anyone know why this may be happening? Appreciate any help!

How did you install pros? The toolchain or VSCode extension?

It looks like they used Atom. And that installed one o the PROS “packages” there. I would recommend installing VSCode by Microsoft instead of Atom and one the interface will be better and you can use the newer VSCode PROS extension. Even if that doesn’t work. Still download VSCode and then install the tool chain and CLI using the PROS website. If you give me your OS I can link the specific website.


I use Mac, thanks for the help!

Now I have VS Code downloaded with PROS extension but when I upload it says:

Make sure that VEXos and the PROS CLI are up to date. If you click “Integrated Terminal” in the PROS Sidebar in VSCode and run the command pros --version, it should tell you your version. The current version of the PROS CLI is 3.3.3.


Where is the download for Version 3.3.3? The newest version I could find is 3.3.2

I’m not sure where you’re looking but the latest version of the PROS CLI can always be found on the Github repo releases page.


If you are using the VSCode extension you should be able to just click “Install PROS” in the PROS Sidebar to install the latest CLI.


However here’s the thing about using the VSCode extension. It seems to be a little buggy on Mac. I have used it and have found some minor issues, mostly with the downloads hanging. I know that @BennyBoy seems to possibly keep track of the issues?, forgive me if you don’t. So hopefully this provides some productive feedback if you happen to need something for a future update or want to look into it. I’ve found some other posters having issues with this and maybe there is a quick fix? Let wanted to let you know.

Original version below (only left because I am willing to admit when I do something wrong or say something wrong.)

Except here’s the thing. I’ve had issue with that in the past. And I am using a Mac. Seems to be issues with a Mac tbh. So would you want to look into that? I’ve seen probably at least 10 somewhat recent threads about VSCode issues with PROS on Mac.

I tried that but it says im up to date. However, when I run pros --version it says it is 3.3.2. I also tried updating it through home brew but that said I am 3.3.3. Am I missing something?

I would love to look into it more in-depth, but it is still summer break so I don’t have access to a Mac. Once the semester starts I should be able to borrow a Mac from other PROS developers and work on identifying and fixing the Mac installer issues. (Intel Macs seem to run into issues more often than M1 Macs for anyone wondering).

However, when I run pros --version it says it is 3.3.2

Although that isn’t all the way up to date, it is still recent enough to where it wouldn’t be the issue causing the NACK you encountered. The only other recommendations I know to give you are making sure that VEXos is up to date (version 1.1.1 iirc), and to try uploading with other cables. Sorry for the inconvenience.


PROS is free software, created mostly by students as and when they can. You don’t have to use it and they have no obligation to fix anything, the whole project could be dropped tomorrow. If it’s not working, move on to something else.

I have not installed the latest version of the extension, I’ll take a look in the next few days. I did have significant issue with the last version, that was related to ssl libraries included with the version of python I had installed among other things.


Ok hold up. I’m really sorry. I did not mean to offend @BennyBoy or any of the PROS dev team. I understand it is created by students. What I was intending is to provide them with some meaningful feedback. I deduced from some of their previous posts that they seemed to help improve PROS, and I just wanted to help them, since many users were having issues and I thought maybe they would have liked to know. I did not mean to complain just help. I also did not mean to make it seem like I was expecting them to fix anything at all. Sorry again for making it seem that way, I just wanted to help. Let me please clarify further. I love the functionality and freedom given by PROS. I really appreciate the student developers taking their own time just to benefit the VEX Robotics community. I don’t expect them to be perfect nor do I expect perfect updates.