PROS (Not?) Uploading

I have been trying to test PID and such in PROS, and my autonomous just will not run. I thought it was something within the methods themselves so I played around with and without methods or my separate method library. When none of this worked, I tried changing things around in user control in a few rounds, just to test. That is when I noticed, my code says it is uploading, it says the upload was successful, but nothing is actually changing.
Has anyone else experienced this?

Remember that you have to successfully compile your code before it generates a file to be uploaded.
If the compiling errors, it will only upload the last successful compile.
Make sure to click “Build” before upload.

I have been building, compiling and uploading successfully, however the issue persist whether wireless uploading or uploading via brain

Strange.
Well, it is quite unlikely it is an issue with PROS.
It’s probably something to do with your code, but I can’t help unless I can see.
Are you by chance trying to change a value in a header?
Because that is bad practice and PROS (gcc + make) will not detect the update in the header file unless you build all.

I can pm you the code.

2 posts were split to a new topic: V5 radio connection problem