PROS on porteus or slackware?

I’m the programmer for my team and this season I’ve decided to switch to PROS. Mostly because I love PROS and think it’s really cool but partly because it means I rarely have to use windows since it’s available on GNU/Linux. I’ve recently gotten a bunch of 8GB flash drive cheaply and decided I’d try some different lightweight distros that can install to a USB thumb drive that I can use if my Linux Mint install goes bad at a mission critical time and I’ve discovered Porteus which I love. I like Porteus so much in fact I’m considering replacing Mint completely with it but the issue is that it’s based on Slackware not Ubuntu or Debian which is needed to run PROS. I’ve tried several utilities to convert the PROS .deb package to a tgz package to no avail. Has anyone else tried/succeeded in getting PROS to work on Slackware, Porteus, or any other distro that isn’t based on Debian? If not it might be time for me to finally figure out ConVEX :stuck_out_tongue_winking_eye:

Not a bad thing, but seriously, PROS = *eclipse+plugins+runtime library. See if you can download eclipse and get that running, then install the plugins from the PROS update site.

*Edit: plus toolchain

Is there way just to get what I need for compiling and uploading the code from the command line? I don’t need Eclipse because I use Emacs.

I should have said plus toolchain. You need to find a toolchain (ie. gcc) that can cross compile for arm. Start by looking somewhere like this.
https://launchpad.net/gcc-arm-embedded

so all I need is the toolchain + runtime library and I can compile and upload my code to the cortex? I think porteus came with GCC, so I think I’m set with the toolchain.

Hmm. Uploading I’m not sure about. PROS had a java based uploader but I think it expects the programming cable to show as a specific device. The gcc you need is probably not the one already installed, you need to cross compile for the arm processor in the cortex. The full name is of the compiler is usually arm-none-eabi-gcc or something like that. I guess you should wait an see if @edjubuh responds as he’s the expert.

Yeah, I found out that the gcc I have is not what I need. I tried getting the latest release from https://launchpad.net/gcc-arm-embedded but the tarbell is corrupt or there’s something wrong with tar (I downloaded it twice so I don’t think something happened while I was downloading it), so I’m trying 4.9-2014-q4-major hopefully that will work. Also, the uploader seems to be in the project folder under firmware/uniflash.jar. We will find out once I get the cross compiler installed.

I’m flattered. I wouldn’t call myself an expert since all I’ve done is bashed my head against the keyboard until things start working :stuck_out_tongue:

We’re currently rolling with GCC ARM Embedded with GCC 4.7.1 on Windows (you can verify this yourself by running


arm-none-eabi-gcc -v

. Interestingly, there is no equivalent version of GCC 4.7.1 for any operating system other than Windows. The Linux installer has historically shipped with GCC 4.6.3, so that’s what we’ll continue doing. I’ve been testing compilation and uploading on Linux and OSX. I have a couple of hours free right now, so I was planning on testing and creating the installers (I won’t be able to test OSX).

The holdup we’re having with releasing them right now is that we were having issues with the flash utility on OSX and, as I recall, Linux, too. Anyway, we’re planning on reimplementing and integrating the flash utility with the new CLI so if the old flash utility is straight up not working, we won’t make a hotfix for the that utility - we’ll just make sure the issue is addressed in the CLI flash utility. In the event that the old flash utility doesn’t work,


make upload

should continue to work as always - we haven’t changed anything there. I’m pretty sure it was a permissions issue with accessing the serial port on Linux and now that I think about it, probably same thing on OSX, but I’m digressing.

If you want to test out PROS on other operating systems before I test and make the installers, a theoretically complete (i.e. potentially complete besides the flash utility) is available on the all-os-support branch of the GitHub repo. The installation process is exactly the same as pre-PROS 1.6.0.0: install Eclipse from eclipse.org then install the features manually, but instead of using https://raw.githubusercontent.com/purduesigbots/purdueros-eclipse/master/update-site/site.xml, you’ll use https://raw.githubusercontent.com/purduesigbots/purdueros-eclipse/all-os-support/update-site/site.xml. That installation process will be better documented soon. I’ve been somewhat flooded since we wanted to get the Windows installers out ASAP since updates to Java straight up broke the old version of Eclipse. Since a lot of our userbase doesn’t use Linux or OSX, we felt comfortable releasing Windows ahead of the other operating systems.

Finally… I’m also planning on making installers (maybe PROS Lite?) that just package the CLI, toolchain, and drivers, if applicable.

Ack… that’s a wall of text but that should give you some insight to what we’re doing and where we’re headed.

cool! So is there going to be official support for Linux systems not based on Debian or Ubuntu?

Sure, if it isn’t too hard to figure out. Debian/Ubuntu will be first priority, though.

cool. Glad to know I it’s at least theoretically possible for me to use PROS if I switch to Porteus. Though I think I’ll wait until this upcoming release to switch though.

I haven’t had the time to properly test the Linux installers as I’m running into a few weird issues that I have to figure out why Eclipse is acting the way it is. I noticed you mentioned you were only planning on compiling/uploading code, so I’ve created a semi-convenient tarball containing the toolchain and CLI. You can grab it here. In order to get compilation to work properly, you’ll need to modify your path to include the toolchain. In your ~/.bashrc (or equivalent file), you’ll add:


PATH=$PATH:/opt/pros/pros-toolchain/bin