pulsing input from vexnet

dont know if this is the right place to put it, but here goes

our team recently got vexnet for the worlds at dallas
all the connections and everything works fine
there some times is a “glitch”, the vexnet will “lag”
so as the drive driver, it is considerably noticeable
i will turn right, and it will take ONE SECOND for it to stop the previous input (forward) and then turn right for ANOTHER SECOND
so basicly there is a one second lag
and it has nothing to do with the code
AND it only happens sometimes (or about half the time)
makes it impossible to drive a 3:1 robot with a one second lag
and the arm driver notices when the arm is lifting too, it pulses at a one second rate
hope i made sense
thanks :slight_smile:

We actually had this same problem and did a bunch of stuff to try to fix it, we aren’t really sure which did it, but I’ll give you a list.

  1. reloading the firmware using the IFI loader
  2. repairing the controller
  3. loading a different version of the code
  4. swapping out the microcontroller
  5. rewiring (everything including the serial)
  6. loading code directly to the controller using the serial cable (not through VEXnet)

I would look through the code to see if anything is causing it, like a 1 second delay :stuck_out_tongue: (just in case it has something to do with the code).

Sorry if this doesn’t help you

hey thanks for the list!
ill troubleshoot it tmrw
dont want a small glitch like that make us loose at worlds do we? :wink:

we tried #4 and #6
we didnt have much time and we didnt know how to do some of the stuff
(the vexnet compatable people wernt there after school today :))
and then we went on #2
and this WORKED
for only 1 min though
we drove around thinking that we fixed it, but when it happened again, we lost our patience
we will troubleshoot some more on monday and hopefully ill get the autonomouse done
(it pulses in autonomous too)

Are you sure you have the most recent master code?

im not sure
ill check today
the latest is v10 right?
crap we did have the latest mastercode…
someone suggested that we were drawing too much current, and the microcontroller was shutting down, but when we tried hooking up crystal, it worked fine with no lag (didnt go back to autonomous if it tripped the breaker)
so now we are trying another microcontroller…
hope that works

crap i think i made it worse
now the robot is not responding at all
vexnet light is green
robot is beep fast red (no back up battery)
we changed the battery
got a 9v battery
swapped out the usb’s
redownloaded the program

going to redownload the mastercode tomorrow (on my laptop)
we connected the usb tether directly to the robot
and it ran (not a code problem)
but it still had the glitching problem

YAY we fixed it!
think it wsa corrupt mastercode or something
the lag/glitching is gone
now we have a new problem
the robot just STOPS RESPONDING periodically
we have ful battery and after 5-7 secs
the robot would just COMPLETELY stop responding
it seems as if the battery went down to 3 volts or something
but after a few secs, its back up and running again at full power
are we drawing too much current?
the motors wernt hot, just normal warm
(this is a different issue now)

Even if the motors don’t feel warm, they might have drawn enough power to go into restart. What was the robot doing when it reset?

it was just running normally
driving with rollers intaking balls
it had a full battery hooked on