Quadrature Encoder Ports

I am a fairly new Vex user. Our team has a cortex microcontroller (model 8322A) and two quadrature optical shaft encoders (model 276-2156). This shaft encoder has two sets of wires. This microcontroller does not have an Interrupt Bank. Open the attached pictures for reference.

We are having trouble finding documentation that MATCHES these two items (controller with encoder). The docs for this encoder show a need to plug one set of wires in to the Interrupt Bank. However, our microcontroller does not have an Interrupt Bank.

Do any of you know how to configure this particular shaft encoder to work with this model of microcontroller?

Thanks for any help you can give this vex rookie.
MicrocontrollerPic_Vex.png
OptShaftEncoderPic_Vex.png

All digital ports have interrupts so plug into any of those pairs of ports. (don’t use port 10 it’s complicated reason why)

Thanks, Tabor!

Since the quad encoder has two sets of wires for each sensor, how do I configure the sensors? Set the “Pragmas”? Should I plug both sets of wires into the digital ports? Which set of wires should I be reading in my code?

The motor sensor setup knows when you make an encoder that it takes up 2 ports. Both need digital ports.

Tabor, I got it figured out. After looking at the auto-configs for the ports, I could see how the 2nd wire was configured in the ports. I really appreciate the help.

Do you know of a cheap, QUICK place to buy the optical quad encoders? Vex takes FOREVER to deliver anything.