RC-110 programming help! Please!

Hey guys, I have been trying to make a rocket launcher for a bit now, and recently my RC-110 PWM switch came in! I posted an older forum about where to put it in, and one of the members told me too put it in the 1-12 ports on the analog/digital port. Please help meh! I am completely stuck on the programming and dont know what too o. My main goal is for me to be able to press a channel 5 button, then ignite the rocket. The circuitry here isn’t an issue. Radioshack and Lowes already got me on that, I just need some programming wisdom/magic!

Which programming software are you using to program the VEX PIC microcontroller?

teehee, I am using EasyC Pro (since its in the EasyC forum)

This not a typical VEX part, so you are going to have to do a little experimenting and hopefully you do not blow anything up. Go to the Online window in easyC PRO. Most switches are controlled with a digital output. The output can be toggled ON and OFF with the check box on the screen.

If this does not work, you may want to try one of the motor ports. I looked up the part # of switch quickly and it mention it was a PWM switch, so it might need to go in one of the motors ports. I do not have this hardware, so I am a little in the dark.

You need to figure out how the switch works with the VEX controller before you can program it.

Thank you for the reply. I tried this and i found something, but not very much. Basically whenever I plugged it in a motor port the gate was closed, but when I plugged it into a digital output/input it was open. Now I tried setting it as a igital input and it gave me values 424/425, then I unplugged it and it was value 1120 (the default value). Another thing I tried was using the Digital Output block, and I set that too “1” and I got nothing… then I set it too “0” and I still got nothing!

What do you think the situation is? I know it can get power from the ports since it worked in the 7.2v motor ports. And it should work below 6v (thats what the switch’s manufacturer recommends anyway). What is the problem?

It might be VeX uses servo PWM and you might need Voltage PWM which is not available on the Vex Controller.

Well it is getting power in the motor ports. There must be some way to completely shut off motor ports.