Rechargable batteries in the Joystick to NOT work

We had a competition this past week…

A robot was brought to the competition in working form. After some practice the robot had communication problems.

We did the basic stuff like resetting - then we swapped wireless keys - then we swapped out the Cortex - then we swapped out the Cortex and the wireless. Then we swapped out the joystick and the wireless and the Cortex. Each time we had problems connecting the joystick to the Cortex. We also did the firmware upgrades followed by choices of joysticks, cortex, and wireless fobs. All to no avail.

The problems disappeared when we made the wise decision to remove the rechargeable batteries and replace them with standard alkaline batteries. (thanks to Jim H for the suggestion)

The joystick light was always green with the rechargables but did not work properly. It would connect and then drop out, connect for a while and work for a while and then drop out again. There were times when the joystick light was bright green and no connection to the robot was made.

My question to the VEX staff is - did we uncover something here? Is this a known problem? Are we getting enough power perhaps to light the LED but not enough current from the rechargeables to keep the connection? At no time was the joystick light orange or red.

In our case, we had two complete sets of controls and both sets worked the same way with the rechargeable batteries. Both sets worked fine with the standard alkaline batteries.

Perhaps some testing from your end could enlighten all of us in the VEX community.

thanks - Dave G.

Hello Dave,

Fully charged AAA batteries in a Joystick showing a green power LED will not cause you to lose your VEXnet Link.

I believe we have a different issue, such as corrosion on the battery contacts of the Joystick or a faulty power connector in the Cortex.
Were you able to drive the robot in tether mode?
Were you using a 2000mAh or 3000mAh battery on the robot?

The only way to track down the problem is to examine your system, please send an email to support@VEXrobotics.com and request a RMA form.

-Eli