Red flash when connecting joystick

The cortex and joystick are not connecting, wirelessly or tethered.
The cortex blinks yellow like it usually does right before establishing a connection, but then all the lights flash red very quickly, and it restarts.

We’ve tried multiple batteries, making sure they’re plugged in tightly.

Our team has had this issue all last year, or at least the same symptoms, but with enough power cycling before a match we could get it to connect.

HERE IS A VIDEO to show exactly what’s happening. First trying to link/connect with a tether, then with the wireless keys. The keys act a bit differently than the tether, they don’t “red flash out”, which makes me think they’re not linked (can’t link because of… well, you’ll see.)
http://www.youtube.com/watch?v=pdUw_dEWcuY&feature=youtu.be

What am I doing wrong? What can I do to fix this?

What have you tried so far?

What firmware are you using? Have you tried re-flashing the firmware? Do you have access to another joystick or cortex to determine which one has the issue?

Hi, we had a similar problem, from the video i think it is coming from the controller (transmitter) … i suggest wipping the entire system (both) and re install firmware … then program, then obviously retether … then vex keys … but as previously said we had a similar problem, and by wiping the cortex, it worked fine again … advise you do the same … generally know i wipe the cortex monthly … and reinstall firmware and program etc …

Is ‘wiping it all’ using the firmware update tool, or doing that hex file thing, or both, or something else?