Red Screen on Controller Cannot Access Power Chip Update

First time forum user here! I am very new to Vex V5 and muddling through the changeover from Cortex. I have been working with my new system and encountered the red screen on the controller that cannot seem to be fixed. I have updated the firmware and the brain is running 1.1.0 currently.

Here are some of the specifics:

  • I loaded a simple program to experiment with the VexCode program and when I turn on the brain the program auto starts and I cannot stop the program using the brain control screen. I have to have the brain connected via USB to the computer to stop the program through the VexCode program.

  • When I power on the brain I briefly see the HOME screen, then an orange power chip firmware update screen, then it goes into running the program. When I stop the program through the computer the screen returns to the program run screen and I cannot access any other screen.

  • I would like to hard reset the brain to erase the programs as I suspect this is what is causing the brain to skip past the HOME screen and the power chip firmware update screen. However, it is my understanding that resetting the brain requires access to the HOME screen and the SETTINGS screen, which I cannot seem to access.

I have attached images of what I see briefly on the screen as the brain powers on. The images are named Screen 1-4 for the order in which I see them. Note: the brain goes through the four screens in about 1 second without stopping and remains on screen 4 until I stop the program through the Vexcode program on the computer.
VexV5_Problem

I hope I have given enough of the specifics. I tried to search for this topic, but I am new to this forum so I apologize if it has been answered/solved prior to this. Any help would be appreciated as I literally have no one to talk to about this except for this community.

Many Thanks!!

1 Like

I’ll send you a DM with a link, go there and follow instructions, you have a brain with production test code on it.

7 Likes

@jpearman Wow! It worked! Many thanks! The battery firmware updated and the controller firmware updated. Just curious, what was the factor in my post that told you there was production test code on the brain? In addition, could this happen to any of my brains at any time? Thanks again!

2 Likes

Screen4, we have had this issue before, some mistakes were made in production a few months ago. Full disclosure, I’m on the dev team for V5 (and many other VEX products)

8 Likes

@jpearman Thanks! I will know what to look for now! Have a great day!

@jpearman
Me again… so now I have a brain that is displaying the same behavior but I see this screen at the end.

I tried the V5 reset link you sent me that worked from before, but it is not resetting the brain. Any ideas?

Thanks in advance!

Should work, it’s the same issue, production test code is running. Is this a brand new brain ?
make sure any other programs that may try and communicate with the brain such as VEXcode or firmware updater are closed.

6 Likes

@jpearman I had Vexcode open so I could stop the program from running and that was interfering with the reset. It worked! Many thanks again! The brain has never been used, but was purchased about 2 1/2 years ago before Covid hit and schools were shut down, so it has never been used.
Thanks again!

1 Like

@jpearman Just as a possible point of interest for you, I have a total of 12 Vex V5 kits and 3 of the brains had to be reset because they had production code on them. Thanks again! Happy Holidays!

2 Likes

We have had a brain that has worked just fine for several years and then today we got this screen? Can I get a link to fix please?

The production test code screen ? I don’t see how that’s possible on a brain that’s been working ok, it was a mistake at the factory and would only happen to new ones. Can you post a photo showing the issue ?

3 Likes

@jpearman responded and will be able to help. Thanks!