Red Screen on V5 remote control screen

Hi, is there anyone here solve issue regarding the red screen, i tried to connect it again in the robot brain but nothing happens… Can someone help me, thanks

Can you be more specific when describing your issue.

The V5 remote control’s screen turns red when it loses connection. If you click its power button the red should disappear.

Also have you tried tuning it off then back on.

1 Like

If the screen is blinking red, try plugging it into a micro USB charger. If the screen is static red and not blinking then either the remote is having trouble connecting to the V5 Brain or the remote needs an update. Tether the remote to the V5 brain using a V5 wire and see if the remote connects and/or a prompt comes up on the V5 brain in regards to updating the controller.

1 Like

This happened to me, I had to send the remote to vex and have them send me a new one, but first call customer support

you might want to try hitting the reset button on the back with a screwdriver or something

I would try to connect the controller and the brain via ethernet. If that doesnt work, try updating the firmware on both the controller and the brain.

Ethernet? 802.3? I thought the only rj45 port was on the v5 controller for competition. I thought the brainy thing only has smart ports. Unless I am mistaken about the v5 brainy hardware.

You are not mistaken – the controller has an ethernet port but it is only used for competition control. A normal smart cable is used to tether a controller to a brain.

Correction, I meant the smart cable port. I always say Ethernet in class and it has carried over. Sorry for the misunderstanding.