Remote Control Troubles


My school’s robotics team recently made the purchase of the vex robotics joystick and wifi-keys. We used EasyC to make a Tank 4 Motor code. Using a Male-Male USB cable, we connected the joystick and the cortex, and the code worked really well- we had full control. However, when we replaced the wire with the wifi keys, the robot did not work.

Here is what happened:
-When first plugged in, the wifi keys glowed blue, just for a second.
-The joystick LED was green, and the VexNet LED on both was orange. This continued for about 5-10 seconds, before both VexNet LEDs went red.
-The robot was unresponsive.

We have tried power cycling, switching keys, other codes, and re-doing the wire paring process.

Is there some sort of initialization process for the wifi keys that we are missing? Are they broken?


I’m not 100% sure about the color codes, but it sounds like your joystick might not be mates to your cortex. You either have to plug the cable in and turn on only the cortex until it links, or plug the cable in and turn on only the joystick until it links (I always forget which it is :()

I’m pretty sure you turn on the remote, not the cortex

I dont think it matters which you turn on. I’d suggest trying redownload the firmware to both the cortex and joystick, then try pair it again.

Here’s a useful page that we have referenced a lot.

VEX Robot Troubleshooting Flowchart

Thanks for responding so soon. If it works with the cable from the joystick to the cortex, doesn’t that mean that it is paired? As for the flowchart, I’ll take a look at this at our next robotics meeting. Thanks again.

Sounds like a firmware issue to me. Make sure to update both joystick and microcontroller firmware, recalibrate joystick after it(very important, see here), and pair them up before use, and make sure that your joystick batteries are full.

The calibration issue cost us a whole tournament and make sure to look it up.