Remotes Disconnect During Match

Hello. Our remotes keep on disconnecting from our robot during the match. We temporarily fix the problem by sticking a screw driver threw the reset button on the back of the remotes. Is there a reason why this keeps on happening? Any help will be appreciated.

V5? If it is don’t hit the rest button you are doing more harm then good if you don not know what the problem is. Also make use the vex radio wire has no bends in it( the wire doesn’t make a sharp turn or fold over its self) and make sure the radio is away from metal (the top part ).

yes, we are running V5 and VCS utilizing C++.

We are replacing the wire for the radio just in case. Thanks for the tip.

We had this issue in a recent competition of ours. Our V5 remote would disconnect, and the light on the radio would go solid red. To reconnect, we would have to either restart the robot (impossible in competition), or power off and restart the controller, which would then reconnect, and the radio would start flashing green again.

We had the exact same scenario.

Hmmm, that’s strange that we both have the same issue. We also weren’t the only team at the tournament to have the issue. Our team replaced both our radio and our brain, and the issue persisted, so I’m guessing this issue is either related to some sort of software bug in V5 / the V5 radio / V5 controller. What I don’t get is why the controller (by controller I mean handheld) doesn’t attempt to reconnect after it loses signal. It should automatically attempt to reconnect, you shouldn’t have to power off and then power on the controller.

Controller is the master, the radio on the robot has to search for the controller, and obviously they are supposed to reconnect unless something has gone really wrong (i.e… crashed) If the led went red, it sounds like you also somehow reverted back to a non-competition radio channel, but I need to check that. Was the field control cable in good condition ?
and Just to ask the obvious, you were updated to vexos 1.0.5 ?

Hi @jpearman , yes, we we’re on 1.0.5. just to clarify, the LED on the radio didn’t just go red, it went solid red, and both the controller and partner controller screens went red and said “connection to robot lost”, and showed Vexnet signal status in the top as searching, aka no signal. We considered the field control cable potentially being an issue, but the issue occurred even when connected to different cables at the field on difference alliance colors. Actually, now that I think about it, we did have some other problems with the radio, where the LED on the cable/port was illuminated, but the LED on the radio for signal status was completely off. I can’t recall whether this was after we lost connection during the match or happened at a separate time. It almost seems to me like a bug with either the radio or controller firmware, but I’m not sure. Also, after we reconnected (power the handheld controller off then on), the LED on the radio on the robot went from solid red back to flashing green, as it should be.

The same happened to us. The same way too.

I had my robot disconnect from the controller but the lights on the radio were still flashing green so it wouldn’t let me reconnect. It happened after I hit a wall in autonomous.

I have also had similar issues. We had the top part of the radio away from metal, the wire had no bends, however during a competition, the controller would just disconnect, even without bumping into anything or any abrupt movement, with the radio showing solid red lights. The only way we could reconnect was by during off the controllers and turning them on again, and then it started working again. But after the competition had ended, the program was still running without showing any signs that there had been controller disconnect, and then maybe 10 seconds after we had disconnected from the field, the controllers automatically reconnected back to the cortex. We even tried unplugging the field control cable and plugging it back in again during a disconnect, however this had no effect, and we ended up restarting the controllers and everything worked again, however in one particular instance, we had controller disconnect, but the controllers didn’t even show the “robot link lost” message. It was very odd. There must be something in the firmware that is wrong because on 1.0.3, we did not have this issue. When not plugged into the field, I have never had a single disconnection from the cortex, even for a split second, so maybe that is another issue. Maybe the field controllers need to receive updated firmware.

1021M had similar issues this weekend. It happened many times during the qualifying matches and it pushed them all the way down to the 14th seed. They fought their way back, but it happened again in the finals. It’s incredibly discouraging for 7th graders that are trying to beat seniors in the finals. They’re also running 1.0.5. I’d love to have an answer for them before next weekend.

Try to use rubber links to attach the radio to the robot in a non-obstructed location in order to reduce vibration and maximize signal strength.

This has been happening to one robot from our school also.

We’ve played four tournaments this year, and the first two were fine. We changed nothing mechanical on the robot, but in the third and fourth tournaments, played in December and January, we lost connection almost every match. We have to turn the controller off and on or remove and reconnect the field cable to regain a connection, and the robot is dead on the field for significant portions of nearly every match while we attempt to deal with the problem.

We’ve tried many things to fix the issue. We tried:

  1. Replacing the robot radio
  2. Replacing the cable connecting the robot radio
  3. Connecting the robot radio to a new brain port
  4. Selecting new locations on the robot for the robot radio
  5. Mounting the radio so that it does not touch the metal frame
  6. Replacing the controller. Three different controllers tried so far.
  7. Resetting the brain and reinstalling code.
  8. Replacing the robot battery cable

However, nothing that we have tried has solved the problem.

We’ve had problems with DCs in the same way. Collisions seem to trigger them, oddly enough. It may be the result of ESD caused by touching two robots together or neutralizing one against the wall, but we’re not really sure.

How about another theory - such as may be the power got loss because of the collision? I am skeptical of the ESD explanation running around the forum - it is a claim for the cause, but with no methodical testing to back it up.

I really don’t think that the power loss could cause that. I’ve seen a few teams whose flywheel has contacted something and gone from full speed to 0 instantly, and although I am sure that it is terrible for the motor to do that, it has not caused disconnects. There are also many teams who play defense much more directly and have not had issues while these collisions were lighter taps, not too much of a stress to the motors.

I watched the video of the failure, I could not determine that it was an ESD related issue or not. I would still say no replay in such situations.

I had a team this weekend that was experiencing this issue at my tournament.

I was under the impression that there would be some sort of error log that would report what happened on the field. I assume if it exists that it gets cleared when the student cycles power remotely. Could we get an update to store error logs on a SD card in the future? If this mechanism doesn’t already exist already.

The Event Log is not lost when the team powers off the robot. On V5 Robot Brain select the Devices icon, then select V5 Robot Brain icon of devices . You will see the inspector view of the V5 Robot Brain. It will display the VEXos version. There should be a button for Event Log VIEW. In VEXos 1.0.5 it lists a fair amount of information regarding connection to the field.