Resistance in Motors when Plugged into Cortex

Hello all,

A few weeks ago, I tried moving both sides of our lift manually using my hand and found a significantly large amount resistance, with the motors “whining” at a higher pitch than normal. After examining our setup and finding no obvious sources of friction, I decided to unplug the two motors powering the arm from the cortex. I discovered that after doing this, there was significantly less resistance and that the motors sounded like they normally do when moved manually. Does anyone know what is causing this?

Here’s a few important things to note:
*]The cortex was off and no batteries were plugged into it.
*]The affected motors were plugged into ports 1 and 10.
*]I’ve tried replacing motors with four others, all with the same issue

Other than this, the motors respond fine during tele-op with no apparent issues. Could it be caused by a short in the cortex? Or is it just a known “quirk” of ports 1 and 10?

Thanks in advance :smiley:

Do you have Analog Deadbands set up?

It could be that, although you were not deliberately using the joysticks to move your arm, the motors were still receiving current due to the sensitivity of the Joysticks. If they are even slightly off-center, the motors controlled by the joysticks may be receiving power. Recalibrating the Joysticks and/or setting up Analog Deadbands would possibly rectify your problem. It will also remove the “whining” that you describe in your initial post.

If this problem was occurring when the Cortex was powered off, or the motors were controlled with digital inputs, I’ve got nothing.

We have analog deadbands, but yeah this is occurring when the cortex is off.

It does not sound normal to me, I just tried with a system and see no difference with the motor plugged in or not and I don’t ever remember seeing this. Sometimes the leds will come on due to the motors acting as a generator but that is all I’ve ever noticed. I though the H-Bridge may be getting stuck in a brake mode (where the motor is shorted) but that is not the standard way of controlling them in the cortex so don’t know why that would even happen.

If you unplug the motor, short it’s input, and turn it do you feel the same resistance? Make sure that there is no power anywhere around when you do this in case you end up shorting the wrong connection.

What rev is your cortex? (on the bottom, NC2, A3 etc)

What software do you use? ROBOTC or EasyC? Which version?

By this, do you mean connect the pins of the motor? If so, the amount of resistance is much greater than when the motors were plugged in.

I don’t know what rev our cortex is since I don’t have it right now, but I can get back to you on that in a day or two.

We use ROBOTC 3.60

Yes, short the red and black wire on the motor (at the two wire connector) together. From what you have said here, it does not sound like the cortex has a short or anything, perhaps there is just a little leakage through the FETs or something, they did change one of them between A3 and A4 versions I think.

Doesn’t sound like it’s anything to worry about.

Alrighty then, that’s good to know. Thanks for the info, jpearman!

Well let us all know if you discover anything else, it’s still a bit of a mystery as to why the cortex is behaving this way, perhaps you should ask in the official support forum, maybe Eli has seen this before.