Responding to "rayedk", posting in "Ask the Experts" Answered: programming errors
I installed the Vex Intelitek easyC programming software on my computer. And no matter how many times I try, whenever I go to download the master code, or test code, it says “make sure the power is one and the wires are connected” (something similar to that). I know that the robot and wires (serial, usb) can’t have any problems because whenever I press the little button on the programming module, it forces the robot into programming mode, yet it still doesn’t download any code. Also, I used the IFI loader, and com4 (what is supposed to be the correct setting for the Vex downloader as I checked it under my computrer’s harware properties) cannot be verified. However, com3 can. I tried downloading to com3 but that didn’t work either. Help would REALLY be appreciated.

Thanks for your time.


You checked in the “Device Manager” that the Prolific USB to Serial is still set to Com4??

If you have the Terminal Window of the “IFI/intelitek Loader” open and set to the Com Port that the Prolific is configured to, and the programming Module plugged in to the Robot, You should see a message on the Terminal Window like “IFI>IFI User Processor Initialized …”

Are you getting any error messages from the “IFI/intelitek Loader” program, when you switch from COM3 (the Modem) to Com4 like “Failed to open port #4!”???

Some programs (like “Palm Pilot Hot Sync” software) will open the Com Port and keep other programs (like “IFI/intelitek Loader” software) from opening the Com Port.

From what you have mentioned so far, I don’t think you have this serial communication working. I have seen (from 4-5 years of experence) that “some computers” look like the “USB to Serial” adapter is setup corectly, but it really isn’t.

BTW, Com 3 (not usually listed in the Device Manager) is the Modem… You won’t get communication with your VEX here…



I have been setting up computers for the local high school to program the VEX bots (MPLAB). I noticed that the USB to serial is coming through on COM3. If that could be a problem, how to I convince the USB driver to use a different COM port?

(Some computers worked fine, others required the use of the “button” on the programmer. All could program.)

Those computer most likely Don’t have a Modem, so Com 3 is a valid port to be use by the USB to Serial device… If you “really” want to change the Com Port, you can in the Device Manager, by Double Clicking on the Prolific USB to Serial Device , and selecting the “Port Settings” Tab, then click the “Advanced…” button and select a different Com Port from the Com Port Drop Down… (Works as of Driver version, Dated 09-APR-2002)

The IFI loader from here will let you send a command from the Terminal. If you have connected to a Modem, sending a “AT” command will get a response of “OK” on the Terminal Screen. FWIIW, sendiing the command “ATI” to my Com 3 Port gets “Agere V.92 Data+Fax Modem Version 8.30” on the Terminal.

I don’t know exacatly on your other question about using the “button” on the programmer module.
There are these two posts in the FAQ section and

In what I have read and observer so far, the PIC Processor in the programmer module must get a signal via the RTS line to start the Programming Process. Which might not always work… I need to hook up my Break Out Box and see what is up…
See here for some RS-232 references: