Robot ATTACK!

Hey there!

I’m sure this is a stupid question but has anyone had the problem of their robot running without them operating it? Our robot has been moving around and hitting things with it’s primitive “arm” attachment all day, and has actually started hurting people. Is this a problem with the trim?

Also, we can’t get the arm to move voluntarily. The only time it moves is when we connect it, and it only moves once. :eek:

We’ve tried everything… HELP! I’ll post a video tomorrow!

Thanks!

“We’ve tried everything”
– If that were true, then you have already tried everything we would tell you.

Safety first: put the robot up on blocks so the wheels don’t touch the ground, and keep your hands and eyes away from the arm, if it is prone to startup jerks.

In a PIC classroom environment, it is a good idea to run with a tether cable instead of a 75MHz Crystal, since there will be other users with the same Crystal number, and they will drive your robot for you by accident (or for sneaky purposes).

It would help to have basic information like this:
Cortex or PIC
Crystal or Vexnet or tethered
USB A-A download or wifi download
EasyC or RobotC or pubdomain

Zipping your program and attaching it would help, if there is a programming problem that makes your arm not move.
If its easy C, you might be able to zoom in on the screen in the video enough to show the program.

Do you have any sort of autonomous segment in your drive program? It’s important to remember that any autonomous code will run as soon as you turn the robot on. We have had team members who forgot this when downloading programs and had the robot attack them.

The title of this post sounds like a horror story. One of our team members thought up a VEX horror story in which a VEX team programs one of their robot’s motors to run at 128 and causes the robot to go on a violent rampage.