Robot battery issues

Hi there, I have a few questions regarding the funtionality of my robot. My class is currently in the robotics unit and we have completely assembled the robots and have had them working perfectly for some time now.

However, just this week, my groups robot has for the most part become disfuntional. One of the main problems that we believe to be the cause here is our battery. As soon as we plug it in to the robot and run it, after about 10 seconds, the “ROBOT” and we eventually don’t have enough power to run the motors.

Heres what we have tried to solve the problem:

  • We have tried 3 different batteries; the “ROBOT” light still turned red

  • We have swapped out the Cortex Microcontrollers (nothing changed)

  • We have swapped out the driving motors (nothing happened)

We currently modified our robot for racing. The frustrating part was that before the modification, we had 5 motors attached: one for the claw, one for the arm, one for a lever that kicked a ball out of the arm, then two for the wheels. Everything was working flawlessly with all of this on there. Then, we take all of that off and only leave 2 motors for the wheels and now it doesnt work…

If anyone could possibly give me some ideas that my group could try to solve this problem, it would be much appreciated.

Also, if I need to post anymore information on the robot, please dont hesitate to ask. I’ll do it ASAP.

Thank you!

It sounds like you have a short in your wiring or a motor plugged in backwards. 10 Seconds could be about the time for the protections to kick in.

The motors are plugged in the correct spots as far as im concerned. The robot will drive forward, only for about 10 seconds before the left motor dies out on us.

I’m not a guru on this stuff, so when you say “for the protection to kick in”, what do you mean? It’s probably something very simple, I’ve just never leanred it. :confused:


Are your motors 2 wire or 3 wire? If the robot is geared for speed, then maybe you’re overworking the motor(s)

I’m not by the robot right now, I’ll have to check. I believe they are two wire motors because we were using an adapter to plug it in to the microcontroller. Which would you recommend using for speed?

We have a 1:7 gear ratio going on right now with no gears on the front wheels. So it’s a rear wheel drive robot. I don’t see that being a problem. Do you?

Geared up 1:7 for speed is going to be a problem with any size wheels.
and notice that anything over ratio of 6 is highlighted in red.

Thank you! So by having such a ratio you think it’s causing the battery to burn out? That would actually make sense considering we changed the gear ratio when we modified it. And before it was working quite well with the ratio it had.
I’ll try changing it back tomorrow morning and post whether or not that was the exact cause.

Thank you guys for all your help. It’s much appreciated.

Its not the battery that is burning out.
It is the over current protection in the CPU or in the motors that is tripping, and takes time to reset.

See also this link. Note that higher wheels speeds mean lower motor speeds with higher torque required, and higher torque requires more current, which is tripping the PTC self-resetting circuit breakers.

Next time you post an update, remember to include all these facts, so responders don’t have to go through the whole thread hunting for them:

  • CPU type (PIC or Cortex)
  • Motor type (old 3wire, or 269 2-wire, or 369 2-wire)
  • wheel size (small = 2.7, 4" medium, or 5" large)
  • gear ratios ( 84tooth gear on motor driving 12tooth gear on wheel)
  • Description of weight of robot (just wheel frame, vs lots of stuff and cargo)
  • What changed since the last time it worked

wow, 1:7!!

try turning the robot upside down and running the motors
do they still stop after ~10 secs?

The motors kept on going after 10 seconds.

Turns out jgraber was correct. I swapped out the gears this morning to a 1:1 and the “Robot” light is all green now and it is running perfectly.

Thank you guys for all of your help!