Robot brain and tethered controller won't move robot at all

Hi! We have started a robotics program at our middle school and are in our first year. We have two kits that run as expected following the starter instructions. We have two that will not run. We have made sure to remove and check the cables connecting the motors to the brain and have checked the tethering cable. We make sure everything is connected before turning the brain on, but we get nothing! We tried changing out the motors. Nothing. We tried the controller on a robot we know works and it controlled that robot. So, we now think it may be a problem with the brain. We are perplexed. Any suggestions?

Again, we followed the starter instructions up to where you test to make sure it runs before deciding on the claw bot or sensor bot.

Thanks!

Hi Sidewynnder,

We’re sorry that you have encountered this issue. To help try to resolve this issue, we have a few questions.

When you mention that the Robot Brain will not run, does the Robot Brain turn on? If not, are you using the rechargeable Robot Battery (p/n 228-2604) or are you using the Robot AA Battery Holder (p/n 228-3493)?

  • If you are using the rechargeable Robot Battery, please ensure that the Robot Battery is fully charged before use.
  • If you are using the Robot AA Battery Holder, please ensure that you are using 6x AA batteries of the same type and age, and that each of these batteries is inserted in the correct orientation - if one of the AA batteries is backwards, the Robot Brain will not turn on. If you are using rechargeable AA batteries, these batteries must be charged in their manufacturer's AA battery charger - they cannot be charged in the Robot AA Battery holder.
  • For more detailed information about using either the rechargeable Robot Battery or the Robot AA Battery Holder, please see Section 1 of the Control System User Guide.
Once the Robot Brain turns on, when you mention that you get nothing, does the Robot Brain connect to the Controller while tethered? Do you see the tether icon in the top right corner of the screen? Can you run the Driver Control program while tethered and drive the robot? If you can drive the robot while tethered with the Tether Cable, the next solution to check is the radios.

If the Robot Brain and Controller communicate via tether but not over wireless, please check the radios in both the Controller and the Robot Brain. For these two devices to communicate, both must use the same type of radio - either the grey 900 MHz Radio (only available in North, Central, and South America), the 2.4 GHz Radio (available worldwide), or the Smart Radio (available worldwide).

After checking to make sure the two radio types match, please check to make sure they are fully inserted into the Robot Brain and Controller. When fully inserted, only about 7-8mm (slightly over a quarter inch) is exposed. On the Controller, you will need to remove the battery door to insert or remove the radio. On the Robot Brain, you will need to press and hold the red button on the bottom of the Robot Brain to insert or remove the radio.

If this has not resolved your issue, and if you are using the Smart Radio, please ensure that you are running the latest firmware. The Smart Radio requires the Robot Brain and Controller firmware to be updated to v1.16 or newer. To update to this version of the firmware, please connect your Controller to the Robot Brain via the Tether Cable, then connect your Robot Brain to your computer with the USB Cable, then turn on t Robot Brain. Launch the VEX IQ Firmware Update Utility, then click on the Smart Radio button at the top, then click the Update All Components button.

If you have any further questions or comments, please contact our technical support folks at support@vex.com or by calling +1-903-453-0802 so we can provide more detailed help and resolve this issue.

Regards,

  • Art

The brain turns on, we get the tether icon, and try to run the driver control program, but it does not run the robot. We are using the rechargeable battery. I will make sure they are fully charged and try again.