Robot Brain Error: "I2C Error on Motor Port"

Hello VEX,

One of the computer brains continues to show the following errors when my students try to operate it using the remote: User Error: I2C error detected on Motor Port 4-6 Reconnect Motor Reboot Brain and User Error: I2C error detected on Motor Port 1-3 Reconnect Motor Reboot Brain. This error continues to repeat after multiple reboots and reconnecting the motors. This error happens when the brain is tethered AND not tethered to the remote.

Things I have tried:
I made sure the firmware was updated on the Robot Brain and motors
I switched out computer brains and the same error appears.
I tried two different remotes without any luck

Please advise.


Hi David,

Sorry you are having this problem.

The I2C Error is displayed when a Smart Motor/sensor on one of the three ports listed momentarily lost communication with the Robot Brain. The most likely cause is when one of the Smart Cable plugs is not fully inserted into the Robot Brain or motor/sensor, and comes loose momentarily when driving the robot around.

Are these errors displayed immediately upon turning on the Robot Brain or do they happen after driving the robot for some time?

If the I2C errors occur after driving the robot for a while, please check to ensure both ends of the cables are fully inserted all the way for the three ports listed. If this does not appear to be the cause, try using different Smart Cables for the motors on the error ports.

let me know the results of these tests.


  • Art